Lucas Epic rotor placement

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Mateusz
Posts: 24
Joined: 11 Nov 2019, 13:01
x 1

Lucas Epic rotor placement

Post by Mateusz »

Image

Have problem with correct rotor placement in lucas epic 2.1td
Im not sure its directed correctly.
Theres is on 2 clock
but in this vid, guy placed it on 10 clock
im lost #-o


User avatar
moizeau
Donor 2020
Posts: 1148
Joined: 12 Jan 2015, 17:08
x 167

Re: Lucas Epic rotor placement

Post by moizeau »

Here's a part of the WM, if you want the rest PM me with your email, it's quite a large file.
Untitled.jpg
Click on the image to enlarge it.
Mateusz
Posts: 24
Joined: 11 Nov 2019, 13:01
x 1

Re: Lucas Epic rotor placement

Post by Mateusz »

Thank you, it help a lot
User avatar
moizeau
Donor 2020
Posts: 1148
Joined: 12 Jan 2015, 17:08
x 167

Re: Lucas Epic rotor placement

Post by moizeau »

Why was the pump stripped? Tickover issue or leak? Just interested....not all things are covered in the manual but there are ways.
Mateusz
Posts: 24
Joined: 11 Nov 2019, 13:01
x 1

Re: Lucas Epic rotor placement

Post by Mateusz »

Cant start engine. To make it run need spray deodorant into manifold. Engine starting and works fine, when its warm i can even shut it down and start again normally without deodorant. But when cool down, it wont boot up, need spray again into manifold.
While working also occured problem, when pushing throotle to 3000rpm and release its staring make tractor noise
I was rebuild all fuel system, new hoses, new filters, kicked out plastic fuel filter, and problem still on.
On injections pipes, fuel not being delivered at the injectors when crank the engine over.
Its look like Lucas not letting flow, lexia also showing problem with "Cam position sensor 2"
and thats why decided to remove pump
User avatar
moizeau
Donor 2020
Posts: 1148
Joined: 12 Jan 2015, 17:08
x 167

Re: Lucas Epic rotor placement

Post by moizeau »

I take it the glow plugs all work, after all this an XUD albeit with an electronically governed pump. There is a sensor on the 1st injector but I don't know what 'Cam position sensor 2' means. If the pump was letting air back in, to stop it starting, I'd expect a leak. Are the mass of wires under the plastic cover in good condition? Over time the insulation breaks down and they can short. Does it turn off straight away with the key or does it take a few seconds? The reason I ask is that the stop solenoid (at the rear of the pump) may be sticking and once started the fuel flow keeps it open, if it hesitates when turning off the other solenoids take over but it doesn't stop as quick.
Mateusz
Posts: 24
Joined: 11 Nov 2019, 13:01
x 1

Re: Lucas Epic rotor placement

Post by Mateusz »

Glow plugs working, i checked them all.
Wires plastic cover was in bad condition. I fixed them by rubber spray to rebuild cover.
The engine stops immediately.
Fuel system was rebuild and dont taking left air now so problem is definitely with pump, it not letting fuel flow to injectors.
I finishing sealing pump and have problem with this spring, it jumped out to my parts box and now i dont know which one is it. I need picture how it look #-o
Image