C4 Cactus - Radiator Fan Issue

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

condeh
Posts: 3
Joined: 06 Oct 2021, 15:01

C4 Cactus - Radiator Fan Issue

Post by condeh »

Hello

Vehicle : '65 Citroen C4 Cactus 1.6 BlueHDI

Issue :
Initially, Engine fault would come on screen, and radiator fan would run at high speed only. No rpm restrictions, and I (foolishly) put this in the "must fix this later" pile, as it had no real impact on using the car. This would occur with or without A/C being turned on.
More recently, when A/C is turned on, within 1-2 minutes, same error comes on screen, radiator fan does *not* run, and rpm is restricted to 3k. With A/C off, this fault does occur but less frequently and I can't replicate it reliably.

A basic phone OBD reader does not reveal any fault codes, and shows coolant temperatures between 85-99 when in fault status.

I'd appreciate any advise. From my online searching changing the fan motor relay 1267J6 appears to be a first step, any wisdom gratefully received!
condeh
Posts: 3
Joined: 06 Oct 2021, 15:01

Re: C4 Cactus - Radiator Fan Issue

Post by condeh »

Sorry I should also add, fan does not appear to run at all, I cant seem to make it run. It does turn freely by hand.
wheeler
Posts: 5182
Joined: 21 Sep 2002, 19:07
x 305

Re: C4 Cactus - Radiator Fan Issue

Post by wheeler »

what happens if you disconnect the coolant temp sensor with the engine running? within a few seconds the cooling fan should come on at full speed. Be aware that doing this will log a fault code with the coolant temp sensor circuit.
condeh
Posts: 3
Joined: 06 Oct 2021, 15:01

Re: C4 Cactus - Radiator Fan Issue

Post by condeh »

Hi, I'll give that a go - would you be able to direct me towards the sensor? I've looked online for a drawing/engine bay picture but struggling to find one that matches