Xantia Ph2 Sunroof Engine/Motor acting strange

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Renanek9
Posts: 38
Joined: 20 Apr 2021, 18:29
x 4

Xantia Ph2 Sunroof Engine/Motor acting strange

Post by Renanek9 »

Hello my friends

Well, another topic about Xantia's sunroof. This system is not at all well designed and it is a headache for many owners from what i could see.

My roof was locked and sliding a little out of alignment. In the first few centimeters it already stopped sliding. After a quick look, i´ve found that the following part where broken
Capturar1.JPG
And, with a little help of some zip ties....
WhatsApp Image 2021-08-07 at 19.04.28 (1).jpeg
WhatsApp Image 2021-08-07 at 19.04.28 (2).jpeg
WhatsApp Image 2021-08-07 at 19.04.28 (3).jpeg
WhatsApp Image 2021-08-07 at 19.04.28.jpeg
Capturar.JPG
Everything where just fine... It was working absolutely perfect and smooth. Here´s a video:



Now, after 3 or 4 weeks (2 of these kept in the garage), I went to open the sunroof and it found itself stucked.

I tried using the emergency crank. No success.... I couldn't turn in any direction. After a few attempts (crank + sunroof button) I managed to get it back up and running.

But now it's working making this weird sound. It sounds like it's "pulsing". Watch the video:



The battery is perfect. Brand new. And it is not possible to observe any changes with the vehicle on or off.

Any help, please?

Thank you guys!
Renanek9
Posts: 38
Joined: 20 Apr 2021, 18:29
x 4

Re: Xantia Ph2 Sunroof Engine/Motor acting strange

Post by Renanek9 »

Anyone please?
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25121
Joined: 15 Sep 2015, 19:38
x 2773

Re: Xantia Ph2 Sunroof Engine/Motor acting strange

Post by GiveMeABreak »

Hi

I can't really help you with this one.

1) It sounds like either something is getting caught only on the opening phase / opening direction - have you checked those cable ties are in place and nothing has come loose and got jammed? Something could be sticking and causing the motor to strain intermittently.
2) Maybe when it got stuck and you forced it open, it has upset the motor gearing? Can't say for sure but it sounds like it is skipping or struggling intermittently on the opening cycle.