xantia speed/oil level sensor - are not used!!

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

User avatar
saeedm
Posts: 59
Joined: 29 May 2021, 11:51
x 13

xantia speed/oil level sensor - are not used!!

Post by saeedm »

hi there.

the engine is xu10j4r with bosch mp5.2 ecu

i was checking speed sensor and then i saw that there isn't any connector for it!
is it not used?!!
also there isn't any connector for knock sensor!!
and there is a white 3 pin connector that comes from electric harness, not used too!!

is it normal?!!

Image

Image
Last edited by saeedm on 12 Sep 2021, 11:29, edited 1 time in total.
ml11ML
Donor 2021
Posts: 46
Joined: 07 Oct 2020, 10:22
x 3

Re: xantia speed/knock sensor - are not used!!

Post by ml11ML »

I also have that blank plug thing on the front of my 2.2 hdi c5 (if I remember correctly, I saw it when I was changing the oil filter). No idea what it does or where the wires go to.
Online
wheeler
Posts: 5112
Joined: 21 Sep 2002, 19:07
x 290

Re: xantia speed/knock sensor - are not used!!

Post by wheeler »

Ive never seen either of these unused on a Xantia, as the Xantia is not multiplexed is wont use the ABS for speed info so there must have been a connector for it. The road speed sensor should have a 3 pin white connector, just like the one you have listed as blank?? Does it reach the sensor?
Same with the knock sensor, i have never seen one fitted but not plugged in.
Has the engine or gearbox been removed recently by any chance?
User avatar
saeedm
Posts: 59
Joined: 29 May 2021, 11:51
x 13

Re: xantia speed/knock sensor - are not used!!

Post by saeedm »

the blank connector can't reach speed sensor, cos sensor is behind engine
that is a pic from wiring harness

Image
Online
wheeler
Posts: 5112
Joined: 21 Sep 2002, 19:07
x 290

Re: xantia speed/knock sensor - are not used!!

Post by wheeler »

What about this plug? looks like it could maybe reach over the top of the gearbox?
The plugs must be there unless someone has cut them off. The speedo would never have worked.
Attachments
connector.jpg
Hell Razor5543
Donor 2021
Posts: 11869
Joined: 01 Apr 2012, 09:47
x 1464

Re: xantia speed/knock sensor - are not used!!

Post by Hell Razor5543 »

It is entirely possible that, for YOUR vehicle, those plugs were not used. Manufacturers might only have a couple of looms for a model range, so some connectors might not be used on 'lower' models, as the quipment was not on that model (but would be for a higher spec model).
User avatar
saeedm
Posts: 59
Joined: 29 May 2021, 11:51
x 13

Re: xantia speed/knock sensor - are not used!!

Post by saeedm »

wheeler wrote:
08 Sep 2021, 18:04
What about this plug? looks like it could maybe reach over the top of the gearbox?
it is one of the intake sensors connector
Hell Razor5543 wrote:
08 Sep 2021, 18:07
It is entirely possible that, for YOUR vehicle, those plugs were not used. Manufacturers might only have a couple of looms for a model range, so some connectors might not be used on 'lower' models, as the quipment was not on that model (but would be for a higher spec model).
this can be true.
User avatar
saeedm
Posts: 59
Joined: 29 May 2021, 11:51
x 13

Re: xantia speed/oil level sensor - are not used!!

Post by saeedm »

update:
it is not knock sensor, actually it is oil level sensor
as shown in pic: (orange)

Image