C4 Picasso air con issue

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Johnno55
Posts: 4
Joined: 12 Jul 2021, 18:14

C4 Picasso air con issue

Post by Johnno55 »

I have a 2013 C4 Picasso platinum with the climate control AC.
Just had speed regulator and heater/blower motor replaced but the AC ( chiller ) only works on max fan speed, even lowering just one speed to 7 the chiller cuts off.
Anybody know why this would happen ?
Even Citroen couldn't discover what the fault was.
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25983
Joined: 15 Sep 2015, 19:38
x 2961

Re: C4 Picasso air con issue

Post by GiveMeABreak »

Has the car been disconnected from the battery recently or stored without using for a while?
Johnno55
Posts: 4
Joined: 12 Jul 2021, 18:14

Re: C4 Picasso air con issue

Post by Johnno55 »

No it hasn't. I had the recent fault of the fan being stuck on and couldn't be turned off or down which led to those recent new parts.
The air con works fine at max speed but not at all below that speed
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25983
Joined: 15 Sep 2015, 19:38
x 2961

Re: C4 Picasso air con issue

Post by GiveMeABreak »

Ok, the reason I asked is that the system memorises values on startup and any disconnection can reinitialise the settings so it can take a while whilst driving to get things working again. Another member has recently done this with the same issue and found it started working on its own after a while.

Try a BSI reset and then go for a drive:

BSI Reset / Battery Disconnect / Reconnect Procedure
Johnno55
Posts: 4
Joined: 12 Jul 2021, 18:14

Re: C4 Picasso air con issue

Post by Johnno55 »

Thanks I'll try it
Johnno55
Posts: 4
Joined: 12 Jul 2021, 18:14

Re: C4 Picasso air con issue

Post by Johnno55 »

Resetting the bsi didn't work.
I've noticed a little dot on the drivers control screen of the air con that flashes on start up, is it supposed to do that as I've never noticed it before