C4GP EGS - New clutch and gearbox fitted, but clutch slips

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Mtl
Posts: 5
Joined: 12 Jul 2021, 17:58

C4GP EGS - New clutch and gearbox fitted, but clutch slips

Post by Mtl »

Hi all,

So my little sister has a C4GP and she had the clutch go on it. I've since had the clutch changed by a mechanic as a surprise for her. But unfortunately the clutch seems to slip when accelerating. I was told the gearbox needed time to relearn. But I'm sure it should not slip.

If I'm on motorway at 50 with cruse on and I press the speed up button. It will slip and revs go to redline and can smell the clutch burning. I'm sure that's not part of the relearn process and it's a brand new flywheel, clutch pressure plate.

I've tried a hard reset, i.e. Floor it from a stand still, no improvement. I've got a copy if lexia coming tomorrow as I'm hoping it's just a calibration issues anyone advise please?
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25983
Joined: 15 Sep 2015, 19:38
x 2961

Re: C4GP EGS - New clutch and gearbox fitted, but clutch slips

Post by GiveMeABreak »

If it's the EGS system it needs recalibrating using the diagnostic tool.

This is for the MK I C4 Picasso from 2007 - you didn't state the year on yours. A VIN would be better to confirm system - but if the former this is the sort of operations needed. The numbers in the last column are the order in which the operations should be performed for each particular operation:
Operations to be performedReplacement: clutch release bearingRemoving - refitting: ClutchReplacement of the clutch
Reading of the countersNo OKNo OKNo OK
Writing of the countersNo OKNo OK7 (Reset the clutch cycles counter to zero)
Depressurisation of the piloting actuator1 (Before replacement)1 (Before replacement)1 (Before replacement)
Pressurisation of the piloting actuator2 (After replacement)2 (After replacement)2 (After replacement)
Bleeding of the air in the hydraulic circuit333
Initialisation of the bite point445
Programming of the piloted manual gearbox grilleNo OKNo OK6
Reinitialisation of the programmed valuesNo OKNo OK4
Learning : Value of the engine torque transmitted to the clutchNo OKNo OK8
Mtl
Posts: 5
Joined: 12 Jul 2021, 17:58

Re: C4GP EGS - New clutch and gearbox fitted, but clutch slips

Post by Mtl »

Sorry it's a 2008. Thanks Marc I'll give that process a go when my lead arrives today and I get diagbox installed and working :)
Mtl
Posts: 5
Joined: 12 Jul 2021, 17:58

Re: C4GP EGS - New clutch and gearbox fitted, but clutch slips

Post by Mtl »

Ok so gone though the process above several times and it still slips on geae change or when you accelerate.

Gonna have to get the guy who fitted the New clutch to sort it. Think it's mechanical jssue.

Unless anyone has any ideas? Or is local Hampshire and can have a look.
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25983
Joined: 15 Sep 2015, 19:38
x 2961

Re: C4GP EGS - New clutch and gearbox fitted, but clutch slips

Post by GiveMeABreak »

My next suggestion would of been the Dual Mass Flywheel - as this can give the same symptoms as a slipping clutch! Are you positive this was done?
Mtl
Posts: 5
Joined: 12 Jul 2021, 17:58

Re: C4GP EGS - New clutch and gearbox fitted, but clutch slips

Post by Mtl »

Yep I'm sure, was billed for it and see the old parts that were removed.

It's an odd slip, gear changes start then it's almost like the car thinks it's shifted and opens the throttle again but the clutch has not fully disengaged on the upshifts.

It also when driving feels like it's always slipping.
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25983
Joined: 15 Sep 2015, 19:38
x 2961

Re: C4GP EGS - New clutch and gearbox fitted, but clutch slips

Post by GiveMeABreak »

It just sounds like it's not programmed properly then which it needs to set the biting point and further it may need the gearbox / clutch actuators recalibrated. It's not something I've had to do personally as I wouldn't set foot near one of these semi-autos.
Mtl
Posts: 5
Joined: 12 Jul 2021, 17:58

Re: C4GP EGS - New clutch and gearbox fitted, but clutch slips

Post by Mtl »

Any idea how to do the above? Ive gone though the lexia/diagbox process and that does the gate/bitepoint/clutch transmission stuff. but no change. Could it be air in the clutch system? i did run the bleed process but no change.
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25983
Joined: 15 Sep 2015, 19:38
x 2961

Re: C4GP EGS - New clutch and gearbox fitted, but clutch slips

Post by GiveMeABreak »

Richard (RichardW) may be the one to help you with this as he's the Picasso Guru and knows about these systems. I've avoided these like the plague for this reason. If he doesn't pick this up at some point, send him a Private message with a link to this thread so he knows what's been done to date.