2014 ds3 rear parking sensors.

This is the Forum for all your DS Automobiles Technical Questions, Problems or Advice.

Moderator: RichardW

alexcramo
Posts: 4
Joined: 09 Jun 2021, 22:39
x 2

2014 ds3 rear parking sensors.

Post by alexcramo »

Hi,
I've just joined as we have just bought a ds3. Its a 1.6 diesel, pretty sweet.
Anyway, the rear parking sensors comes up with the service light and the parking sensor fault on the screen when I go in reverse.
I thought I'd have a look like you do, I took all 4 sensors out, marked each one, then metered them with a multimeter. 3 out of 4 showed around 1.5m ohm. 1 showed approx 200 ohms. Thiught, brilliant, I opted for a used genuine sensor instead of a brand x, measured it, got around 1.5m ohm, brilliant, put it on the car, absolutley no change. Does anyone have any ideas?
As a side note, my wife says the radio is quite poor, is it possible the previous owner had a different stereo and replaced the original to sell? Could this affect the use of parking sensors? Just an idea...
Thank you for any ideas you may have.
User avatar
GiveMeABreak
Forum Admin Team
Posts: 26087
Joined: 15 Sep 2015, 19:38
x 3000

Re: 2014 ds3 rear parking sensors.

Post by GiveMeABreak »

Yes, that's a possibility of course as the head units are programmed for specific features on the vehicle which includes that type of parking assistance.

If you post up your VIN and a photo of the head unit / central console I may be able to see what you appear to have against what you should have.

The parking assistance ECU checks the components when the system is activated. If any part is faulty it cuts out the system for obvious reasons. A diagnostic should also indicate the specific fault code which would be useful.
alexcramo
Posts: 4
Joined: 09 Jun 2021, 22:39
x 2

Re: 2014 ds3 rear parking sensors.

Post by alexcramo »

Thank you Marc, I have the original stereo back in now, and I took it out at lunch time, all cables/connections seem secure. The menu has parking sensors on, and the rear wipe activated when in reverse, I checked this wiper function and it works. The Stereo doesn't turn the volume down when reverse is engaged, does this give a clue? I found the Sensor ECU in the driver side boot compartment, all looks okay.

Agreed, I was going to book into Citroen for a diagnostic, I'm only just learning about this lexia thing Citroen use. Until then I might test the wiring harness from the ECU to the 4 sensors just until I can get to the garage, do you think that's worth doing?

Thanks
User avatar
GiveMeABreak
Forum Admin Team
Posts: 26087
Joined: 15 Sep 2015, 19:38
x 3000

Re: 2014 ds3 rear parking sensors.

Post by GiveMeABreak »

The volume should indeed be lowered when reverse is engaged with a parking assistance system. It may be that somebody has changed the configuration. Have they ever worked since you purchased the vehicle?

Citroen will charge you about £60 for a diagnostic which is the standard charge, but I would ask them to check the configuration in case somebody has mucked about with this (previous inexperienced owner with a diagnostic kit :roll: )

The official diagnostic tool that Citroen uses can tell which exact sensors (if any) are faulty, but as for the radio volume reducing - it may not reduce if the system is not active because of a fault - so hard to know at this point.
User avatar
Paul-R
Donor 2020
Posts: 5446
Joined: 07 May 2009, 16:24
x 805

Re: 2014 ds3 rear parking sensors.

Post by Paul-R »

Are we sure that the volume reduces on simply engaging reverse gear? I have a feeling that on our two cars the volume only reduces when the sensors start beeping.
User avatar
GiveMeABreak
Forum Admin Team
Posts: 26087
Joined: 15 Sep 2015, 19:38
x 3000

Re: 2014 ds3 rear parking sensors.

Post by GiveMeABreak »

I'm sure the Op can check that out on his particular car whether he has to start moving or not for the volume to decrease - but personally speaking from my Aircross, my volume reduces as soon as I engage reverse and the beeps start immediately, but slowly and steady - this is at standstill with nothing behind.
alexcramo
Posts: 4
Joined: 09 Jun 2021, 22:39
x 2

Re: 2014 ds3 rear parking sensors.

Post by alexcramo »

Weve only had the car a few weeks, so its never worked and its my bad, I never checked when I was buying it, ultimately it'll cost me!

The only time the error occurs is the first time you go in reverse. After that, the error doesn't show, but also the sensors don't work, I'm guessing the first time is the car shutting the module down? And after that i.e. the second time you go in reverse, it doesn't even bother trying to use the sensors.

Even on the first time you go in reverse the audio doesn't go down.

Whatever I find with the Citroen diagnostic ill post on here. Out of interest will they happily just give you a print out of all/any errors and take the £60? Or do they try and get you to agree for them to do the work? I've never just taken a car to a main dealer for a diag only.

Thanks
User avatar
GiveMeABreak
Forum Admin Team
Posts: 26087
Joined: 15 Sep 2015, 19:38
x 3000

Re: 2014 ds3 rear parking sensors.

Post by GiveMeABreak »

You are entitled to the report as you are paying for the diagnostic. Just ask them for a print out of the diagnostic as you may need it later for reference purposes. Sometimes they may knock the cost of the diagnostic off any work if something needs replacing - just ask them up front. Yes, the system self diagnosis on first use and will record the fault and deactivate - it may or may not try to re-engage the next time you go into reverse or may stay deactivated until you switch the engine off and restart.
User avatar
Paul-R
Donor 2020
Posts: 5446
Joined: 07 May 2009, 16:24
x 805

Re: 2014 ds3 rear parking sensors.

Post by Paul-R »

Paul-R wrote:
10 Jun 2021, 14:55
Are we sure that the volume reduces on simply engaging reverse gear? I have a feeling that on our two cars the volume only reduces when the sensors start beeping.
I checked on our 308 today and the volume reduces exactly as I said. There's a single beep as you engage reverse (without volume reduction) and then as you reverse up to an obstacle the beeping starts and the radio volume reduces.
User avatar
GiveMeABreak
Forum Admin Team
Posts: 26087
Joined: 15 Sep 2015, 19:38
x 3000

Re: 2014 ds3 rear parking sensors.

Post by GiveMeABreak »

The systems are obviously not the same across the models in all cases.
User avatar
Paul-R
Donor 2020
Posts: 5446
Joined: 07 May 2009, 16:24
x 805

Re: 2014 ds3 rear parking sensors.

Post by Paul-R »

Which is why I asked the question. It may be that there is no fault but designed that way.
Tony2561
New User
Posts: 1
Joined: 06 Jul 2021, 10:23

Re: 2014 ds3 rear parking sensors.

Post by Tony2561 »

I have a 2016 ds3 diesel which has the same fault, going into reverse a warning beep and warning comes up on my display there’s a fault. After this the reverse sensor doesn’t work...

I had work done in a garage to my steering after that it’s never worked...

Have no idea how to sort this so hopefully someone on here might know.
User avatar
GiveMeABreak
Forum Admin Team
Posts: 26087
Joined: 15 Sep 2015, 19:38
x 3000

Re: 2014 ds3 rear parking sensors.

Post by GiveMeABreak »

The only way you will sort it is to have it diagnosed properly with a suitable dealer-level diagnostic tool. This will be able to determine if it is a sensor or the system as a whole.

The system undertakes a self check each time it is activated, but if it detects a faulty sensor for example, it deactivates for safety reasons and sends a fault message to the display in the dash / multi-function screen.

Now it may be a coincidence in that you do have a faulty sensor, as they do fail at some point if water runs back down the loom to the sensor plug and gets inside, or it is possible that somebody has damaged the loom or a sensor. The sensors are very 'sensitive' and do not take well to knocks or being dropped. If it is a sensor that is faulty, Diagbox or a suitable diagnostic tool will be able to determine which sensor is faulty if applicable. If it is a communication issue, then this can be caused by damage to the wiring loom - but we can't be sure until you have had a diagnostic run on it.
alexcramo
Posts: 4
Joined: 09 Jun 2021, 22:39
x 2

Re: 2014 ds3 rear parking sensors.

Post by alexcramo »

Hey,

Sorry for not posting sooner. Got the problem fixed.

I booked a day off work, having booked a diagnostic at Citroen, turned up, despite me showing them the booking email, they had no record of me, and suggested I book for the week after. I'm very stubborn, and decided id try another route. Did some research and bought a diagbox tool, off eBay, a gamble, but for the money worth trying. Anyway, turned out there were 2 more faulty sensors, bought 2 more, replaced them, and voila, fault gone. Been fine a few months now.

On a side note, the diag tool, took a little working out, but it works well, and already paid for itself.
User avatar
GiveMeABreak
Forum Admin Team
Posts: 26087
Joined: 15 Sep 2015, 19:38
x 3000

Re: 2014 ds3 rear parking sensors.

Post by GiveMeABreak »

Well done - these can fail at similar times - I also had one go on my old C5, then another went within a few days and finally a third one!