Security support for old browsers from 1 September 2021

Forum News, Announcements and any issues you're having with the forum

Moderator: myglaren

User avatar
xantia_v6
Forum Admin Team
Posts: 7909
Joined: 09 Nov 2005, 23:03
x 513

Security support for old browsers from 1 September 2021

Post by xantia_v6 »

We have been notified by the organisation that supplies our security certificates that support for some old browsers will expire on 1 September 2021.

This only affects relatively old devices, such as the iphone 4 and earlier and some old unsupported browsers on other devices and PCs.

In broad terms, the security certificates for a web site are built as a chain from a root certificate, with each certificate having an expiry date. In this case the old root certificate will expire, but old devices which have not had a software update in several years will not recognise (and not trust) the new certificate.

This does not affect the security of the site, and for such old devices should not impact the browsing experience, except that they may henceforth report this site as being insecure.

For a more detailed explanation, see: https://letsencrypt.org/docs/dst-root-c ... mber-2021/
User avatar
mickthemaverick
Donor 2021
Posts: 7396
Joined: 11 May 2019, 17:56
x 2099

Re: Security support for old browsers from 1 September 2021

Post by mickthemaverick »

xantia_v6 wrote:
12 May 2021, 22:10
We have been notified by the organisation that supplies our security certificates that support for some old browsers will expire on 1 September 2021.

This only affects relatively old devices, such as the iphone 4 and earlier and some old unsupported browsers on other devices and PCs.
I take it this refers to the hardware Mike, not the user? :-D
User avatar
xantia_v6
Forum Admin Team
Posts: 7909
Joined: 09 Nov 2005, 23:03
x 513

Re: Security support for old browsers from 1 September 2021

Post by xantia_v6 »

mickthemaverick wrote:
12 May 2021, 22:18
xantia_v6 wrote:
12 May 2021, 22:10
We have been notified by the organisation that supplies our security certificates that support for some old browsers will expire on 1 September 2021.

This only affects relatively old devices, such as the iphone 4 and earlier and some old unsupported browsers on other devices and PCs.
I take it this refers to the hardware Mike, not the user? :-D
It depends when their firmware was last updated...