C4GP 07 1.6 VTR EGR replaced but handbrake faulty again

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

DanielG2021
Posts: 21
Joined: 09 Mar 2021, 15:08

C4GP 07 1.6 VTR EGR replaced but handbrake faulty again

Post by DanielG2021 »

C4GP 1.6 2007 auto HANDBRAKE FAULTY (egr replaced)
Hi everyone I am hoping somebody can help me with this now because I can’t take much more of this car lol

Since about October last year i got handbrake faulty warning randomly flash on starting the car but then instantly disappear. Then in February I got the same error then couple days later it turned into asr esp error which got worse over a couple days to the point where it was constantly on then it added de pollution error to it. I got it checked by two diagnostics one from my brothers Delphi reader which threw up P0405 error EGR SHORT TO A. The car was driving fine with the error but then MOT was due there first of March and the garage checked his software and said same error EGR.

I ordered a Delphi EGR EGR VALVE FITS CITROEN FIAT FORD MAZDA MINI PEUGEOT DELPHI EG10401-12B1 from eBay for £97 and the garage fitted it for £80. Before the egr was replaced the service light and handbrake faulty was constant on turn of the engine with all the errors. When the mechanic replaced it there was no errors and for three weeks it’s been fine, until I got the handbrake faulty error a couple weeks ago on turn of the engine straight on straight off, then few days ago i got service light but then went straight off and today I’ve had handbrake faulty again on start of the engine then straight off but no esp asr errors.

Could this be a failing EGR again because I’ve bought a dud from eBay or something else? I can’t get service light or engine light to stay on to read any faults so not sure what’s causing it.

DanielG2021
Posts: 21
Joined: 09 Mar 2021, 15:08

Re: C4GP 07 1.6 VTR EGR replaced but handbrake faulty again! BATTERY?

Post by DanielG2021 »

I’ve uploaded a couple videos to YouTube of the fault





I haven’t used the car for couple days and when starting this morning it seems to be throwing the faulty handbrake up nearly every start and if I put the radio and lights etc on it seems to be on more. I am going to get the battery checked tonight from the local mechanic. Anyone else has any issues like this?