07 c4gp 1.6 VTR weird idle noise

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

DanielG2021
Posts: 21
Joined: 09 Mar 2021, 15:08

07 c4gp 1.6 VTR weird idle noise

Post by DanielG2021 »

Hi everyone

Trying to figure out what could cause this odd noise when my c4gp is idling, it sounds like vibration/knocking but soon as I pick up revs it’s fine and driving the engine is fine, it’s usually not there when you start car either takes a few minutes then it appears, usually can hear it after stopping to park up or when I stop at stand still at lights etc. When I lift the bonnet I cannot hear it but sitting in the driver seat I can hear it.

Tried to upload a recording of it here https://voca.ro/16Y8GcCSEHx6

My brother said it sounds like a sticky lifter? Should I be worried or is this just noise of a diesel ?

RichardW
Forum Treasurer
Posts: 9489
Joined: 07 Aug 2002, 17:12
x 435

Re: 07 c4gp 1.6 VTR weird idle noise

Post by RichardW »

What's the history of the turbo and injector seals on this car?

Hate to be the bearer of bad news, but that is just the sort of noise ours was making before the sump strainer blocked up and we got low oil pressure. Luckily the engine survived, and ripping the strainer out of the sump pick up stopped it happening again. Ours had a noticeable rattle at cold start for a second or so however.

DanielG2021
Posts: 21
Joined: 09 Mar 2021, 15:08

Re: 07 c4gp 1.6 VTR weird idle noise

Post by DanielG2021 »

I’ve only had the car a year in March and can’t see if it’s had much work it did have service history from local garage every year, I believe it was ex mobility car.

I had a fiesta before this that had a rattle which was heat shield but this is odd because to me it sounds like a spitfire lol in the drivers seat not extremely loud but noticeable. It appears when car seems to be warm and not noticeable when cold. Usually after letting it tick over a bit and giving it done revs after few minutes you can hear it slowly appear. To me it sounds more like a rattle like something vibrating behind the dash in the drivers seat but not sure, if you stick head under the bonnet I can’t hear it

I know the timing was done when I bought it and it’s done 57k on the clock, the egr had went last month and after your advice Richard it was replaced and seemed to solved the depollution, handbrake faulty esp asr errors

DanielG2021
Posts: 21
Joined: 09 Mar 2021, 15:08

Re: 07 c4gp 1.6 VTR weird idle noise

Post by DanielG2021 »

i've got it booked in at my local garage for end of next week to see if they can investigate the sound, its been like this months and i always just put it down to a heat shield or something rattling but i am more concerned now its something more serious. Its very strange that when i start the engine it sounds lovely but soon as i say reverse and brake or drive to the end of my street and stop then pull away it appears.

DanielG2021
Posts: 21
Joined: 09 Mar 2021, 15:08

Re: 07 c4gp 1.6 VTR weird idle noise

Post by DanielG2021 »

So I started the car this morning to take my daughter to work after not using it yesterday and beeep service light soon as engine started but straight off with no warning. Engine light and service light was on then straight off. I was wondering if a old battery would could cause problems like this ? I have started the car about 5 times since this morning and no service light or beep. I haven’t got a battery checker but I noticed ontop of my battery under the plastic cover I have some water that’s keeping dripping down from the tiny gap from scuttle at the bottom window. The water is lying around the terminal.the scuttle looks fitted as best it can but water still seems to leak down and drip through the carpet like material

DanielG2021
Posts: 21
Joined: 09 Mar 2021, 15:08

Re: 07 c4gp 1.6 VTR weird idle noise

Post by DanielG2021 »

GOOD NEWS solved the rattle it was the aircon pipes I believe on the drivers side, the clip was broken what holds them and when they moved slightly back it was making that noise.

The service light is another issue, came on again BEEP and illuminated service light then it goes off within seconds.

Not sure how to diagnose the problem unless the service light stays on.

I did put redex and fill car up few days ago but can’t see this causing service warning