Blower not working

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

C4_owner_pj
Posts: 2
Joined: 08 Apr 2021, 14:48

Blower not working

Post by C4_owner_pj »

Hi,

I have been reading a lot of threads having the same problem. Blower not working. But I cant seem to find out if there can be a relay thats defect or not in my model. It seems to me my blower works (tested on battery) and resistor pack seem to work as well. I tried measuring voltage and it seems to be the blower does not get any power. What components can be causing the blower not to get power?

Its a C4 Grand Picasso 2010, VIN VF7**************[VIN obfuscated, can be read by forum staff].

The blower when it started to fail worked occationally. Sometimes worked, next time didn’t work. So it just got worse over time and now its totally dead.

ozvtr
Posts: 50
Joined: 13 Oct 2020, 01:11
x 8

Re: Blower not working

Post by ozvtr »

Sorry but i don't have a circuit diagram for your car but the circuits generally follow the same pattern.

Typically power comes from the battery through the maxi fuses (under the BSM fusebox in the engine bay) to the BSM, through "blower fan" fuse, switched by a relay in the BSM. Then to the positive of the fan motor, through the fan, to the selector switch, to the resistor pack then to ground.
Typical failure modes are:
Burnt out resistor. Can be tested with a multimeter on ohms.
Burnt out contacts in the selector switch. Can be tested with multi meter but better to pull it apart and look. Test for voltage at resistor.
Burnt out contacts on fan motor or burnt out motor. You have apparently tested the motor?
Burnt out contacts on connectors between components. Remove all the associated connectors and inspect the contacts for carbonization or melted plastic.
Burnt out contact of relay in BSM. Test for volts at the positive terminal of the fan with the fan running, or set to 'on' if it's not running.
Blown or bad "blower fan" fuse. Test for voltage on both sides of fuse.
Blown or bad maxi fuse. This will power other circuits so if nothing else has stopped working, unlikely to be that.

C4_owner_pj
Posts: 2
Joined: 08 Apr 2021, 14:48

Re: Blower not working

Post by C4_owner_pj »

Thanks for the reply. I have used a multimeter to test the voltage when fan is on, and I got 0 voltage. The resistor seems to be good when testing resistance (ohms). I do want to check if I have chekced the right fuse and see if I can find a relay to test. My problem there is that I am unsure which fuse, but I have checked the ones I found in the cars manual, and some more (Have not measured voltage on fuse). I really want to find and test the relay, but I do not know where tis is. When you say in BSM I cant seem to find many relays. There is one green one tucked in front of the BSM, but I have no idea what that one is for. I am not at home now, but can take som picture of BSM and post when I am back home.