C5 X7 Rear Suspension Fault

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

User avatar
DHallworth
Donor 2016
Posts: 2297
Joined: 20 Nov 2005, 18:05
x 72

C5 X7 Rear Suspension Fault

Post by DHallworth »

Our recently acquired 3.0 HDi Exclusive (Saloon) has a strange fault with its rear suspension.

If you drop the suspension to it's lowest setting and then press the button to return it to normal height, the front will go to normal height but the rear suspension will stay on the floor. If you then press the "Up" button again, the front and rear will both raise to the intermediate height.

Pressing the down button will then drop the car to it's normal ride height and it'll sit there perfectly level.

When you unlock the car or open a door it'll level the front and rear with no problems, the problem only seems to happen when the car is dropped to its lowest setting.

When I initially scanned the CSS ECU on the car I got the following:

C1184 - Reference heights not programmed
C1195 - Front axle average movement
C1196 - Rear axle average movement
U2003 - Main wake-up
P0562 - Under voltage

The car has been sitting around for 3 or 4 months so the voltage faults are to be expected. I've cleared all the faults off it and the only one that's come back is "C1184 - Reference heights not programmed".

There is a receipt in the service history for a rear height sensor being replaced. I'm wondering if something has gone wrong whilst they've been trying to set the heights.

Would this cause the rear not to rise when going to normal height?

Would appreciate any thoughts before I dive into the wrong thing!

David.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 23239
Joined: 15 Sep 2015, 19:38
x 2446

Re: C5 X7 Rear Suspension Fault

Post by GiveMeABreak »

You should be able to get some live data on the suspension David. IT should show you the front and rear current values against the reference values - what are these showing?

User avatar
DHallworth
Donor 2016
Posts: 2297
Joined: 20 Nov 2005, 18:05
x 72

Re: C5 X7 Rear Suspension Fault

Post by DHallworth »

Thanks Marc, I totally forgot you’d be able to interrogate each sensor with Diagbox.

I’ve had it plugged in tonight and have concluded that something is a miss with the rear right height sensor. It’s supposed to have had a new one so am wondering if it’s not seated properly, failing that, it looks like it’s knackered. The fronts aren’t right either I don’t think so I’ll get under it and have a proper look at the height sensors and the linkages.

Video below:



Hoping it’ll behave itself long enough to get an MOT on it tomorrow.

David.