Need help with eolys Elloys fault

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

14c4picasso
Posts: 2
Joined: 26 Feb 2021, 23:07

Need help with eolys Elloys fault

Post by 14c4picasso »

Hi,
I have a 2014 c4 picasso 1.6 diesel, 3 days ago I took it in to my local independent car garage to have its Elloys fluid topped up as the car has done 50k miles, once I collected car it was in limp mode the garage are refusing to accept they caused this, it was fine when I took it in I got a mate to do a read with his snap on reader and the main fault code was P1435 (multiplexed additive pump Can network fault or pump fault) so he is suggesting I replace the pump, but up until getting it topped up it was fine no warning lights.
But am I right in thinking citroen has a strange way of resetting the fluid count on another ecu not the actual engine management ecu? I just wonderd if I should look more into this before replacing pump.
Any advice would be greatfully appreciated,
Thanks in advance, Joe.

wheeler
Posts: 4738
Joined: 21 Sep 2002, 19:07
x 228

Re: Need help with eolys Elloys fault

Post by wheeler »

Have you checked that the electrical connector has been plugged back in properly?

User avatar
GiveMeABreak
Forum Admin Team
Posts: 23240
Joined: 15 Sep 2015, 19:38
x 2446

Re: Need help with eolys Elloys fault

Post by GiveMeABreak »

Hard to say who's at fault - but it depends on which 1.6 engine you have as to whether there is a separate fuel additive ECU or not. If it's the DV6TED4 then it has a separate additive ECU, if it's a DV6C then the function is controlled by the engine ECU.

So do check that the connections as mentioned - but if you have the DV6TED4 110 engine, then the P1435 does suggest the additive pump as suspect, although it could be the ADDGO additive ECU.

14c4picasso
Posts: 2
Joined: 26 Feb 2021, 23:07

Re: Need help with eolys Elloys fault

Post by 14c4picasso »

Thank you both for you helpful input and advice, I jacked the car up today and took the tray off fiddled with all connectors and one of them clicked, now car is running fine and codes self cleared, annoyingly I had already orderd a lexia kit to try and clear the code, hopefully I will make use of it in the future thanks again for your help

User avatar
GiveMeABreak
Forum Admin Team
Posts: 23240
Joined: 15 Sep 2015, 19:38
x 2446

Re: Need help with eolys Elloys fault

Post by GiveMeABreak »

No problems - get the flipping garage to pay for it!