1.9d berlingo blowing 20amp ecu fuse

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

Jonny555
Posts: 4
Joined: 16 Jan 2021, 14:45

1.9d berlingo blowing 20amp ecu fuse

Post by Jonny555 »

Hi just new to this but used my 1.9 D berlingo to jump start a small tractor now my van just keeps blowing the 20amp ecu fuse can anyone advise r help me thanks

User avatar
GiveMeABreak
Forum Admin Team
Posts: 22603
Joined: 15 Sep 2015, 19:38
x 2339

Re: 1.9d berlingo blowing 20amp ecu fuse

Post by GiveMeABreak »

You're the second person this week that has done this - the other chap had the engine running whilst connecting and has likely damaged an ECU, sorry to say.

There is a correct way of attaching the leads and before the engine is started to avoid potential damage. You may have damaged an internal component of the engine fuse box - but hard to be sure without a thorough investigation / testing.

wheeler
Posts: 4648
Joined: 21 Sep 2002, 19:07
x 212

Re: 1.9d berlingo blowing 20amp ecu fuse

Post by wheeler »

Does it blow as soon as the igniton is switched on before starting?
If so try disconnecting the ECU & see if it still blows when you switch the ignition on.

User avatar
white exec
Moderating Team
Posts: 6558
Joined: 21 Dec 2015, 13:46
x 1123

Re: 1.9d berlingo blowing 20amp ecu fuse

Post by white exec »

Disconnect the battery before disconnecting the ECU - just to be safe.

Jonny555
Posts: 4
Joined: 16 Jan 2021, 14:45

Re: 1.9d berlingo blowing 20amp ecu fuse

Post by Jonny555 »

Hi she blows before trying to start when ecu is disconnected it doesn’t blow

wheeler
Posts: 4648
Joined: 21 Sep 2002, 19:07
x 212

Re: 1.9d berlingo blowing 20amp ecu fuse

Post by wheeler »

Oh dear, did you connect the leads the wrong way around? this is quite common on Berlingos as if I remember right both the battery leads are black?
What year is it?

Jonny555
Posts: 4
Joined: 16 Jan 2021, 14:45

Re: 1.9d berlingo blowing 20amp ecu fuse

Post by Jonny555 »

She’s 06

wheeler
Posts: 4648
Joined: 21 Sep 2002, 19:07
x 212

Re: 1.9d berlingo blowing 20amp ecu fuse

Post by wheeler »

Im guessing its a Lucas DCN2 ECU then?
Something is making me thing that this ECU maybe not coded and that its only the BSI & stop solenoid in the pump that is coded. The ECU on this engine only really controls the advance/retard of the timing & the EGR operation.

Jonny555
Posts: 4
Joined: 16 Jan 2021, 14:45

Re: 1.9d berlingo blowing 20amp ecu fuse

Post by Jonny555 »

So wat u think is best fix

wheeler
Posts: 4648
Joined: 21 Sep 2002, 19:07
x 212

Re: 1.9d berlingo blowing 20amp ecu fuse

Post by wheeler »

I'd open the ECU casing & have a look inside for any visible burning, if there is none visible there may be a chance of getting it repaired.
Normally on modern PSA cars the BSI, ECU & key are a matched set so using a second hand ECU wont work unless you have the full set but something makes me think on the DW8 engine one of them is not coded to each other as the stop solenoid is coded. Cant remember 100% though.