C4 Not Starting

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

DeadC4
Posts: 5
Joined: 12 Dec 2020, 17:49

C4 Not Starting

Post by DeadC4 »

Evening all. I've been given a 2007 C4 1.6 that was destined for the scrapyard after it cut out on its previous owner and they couldn't get it started again. It's got just over 100k on the clock and is otherwise in reasonable nick, so it I'm determined to get it going. I've got several years of DIYing my own car repairs, but my experience with engines is rather limited so I'm hoping you can help.

Here's what I know from my own tinkering so far:

The starter runs and the engine turns over including the camshafts.
Fuel and air are getting to the engine.
There is compression on all 4 cylinders. The inner two are a bit lower than the outer two but they all have it.
All 4 plugs are sparking.
There are no fault codes showing, no immobiliser issues and no blown fuses.

It does have some history of coolant loss. The previous owner would wait for STOP to appear before topping it up. This would be around once a month. It was obvious to me where the leak is straight away, but chances are damage has been done.

This is where my knowledge ends. What's the next step please guys?

Thanks a lot :)

User avatar
xantia_v6
Forum Admin Team
Posts: 7636
Joined: 09 Nov 2005, 23:03
x 434

Re: C4 Not Starting

Post by xantia_v6 »

Hi, and welcome to the forum :-D

There are several different variants of engine that could have been fitted to your car. It will save time if we know which one you are dealing with. If you reply with the VIN number, we can look up the specification.

petarc1971
Posts: 46
Joined: 01 Mar 2019, 20:50
x 7

Re: C4 Not Starting

Post by petarc1971 »

To begin with, he would check the condition of the fuel tank (presence of impurities), the condition of the fuel pump, the fuel pressure in the rail, the condition of the nozzles, the condition of the exhaust-catalyst.

DeadC4
Posts: 5
Joined: 12 Dec 2020, 17:49

Re: C4 Not Starting

Post by DeadC4 »

Hi, thanks for the replies.

VIN is VF7**************[VIN obfuscated, can be read by forum staff]

I don’t think it’s a fuel delivery issue. It’s definitely coming through as it spurts out when I press the pin on the valve. I’ve also tried starting spray and get nothing.

Cheers.

DeadC4
Posts: 5
Joined: 12 Dec 2020, 17:49

Re: C4 Not Starting

Post by DeadC4 »

TU5JP4 engine I believe

DeadC4
Posts: 5
Joined: 12 Dec 2020, 17:49

Re: C4 Not Starting

Post by DeadC4 »

Peered through the top of the timing belt cover and can confirm that it is intact

DeadC4
Posts: 5
Joined: 12 Dec 2020, 17:49

Re: C4 Not Starting

Post by DeadC4 »

Any ideas anyone? Just bumping the post. Thanks.

Hell Razor5543
NOT Alistair or Simon
Posts: 11142
Joined: 01 Apr 2012, 09:47
x 1207

Re: C4 Not Starting

Post by Hell Razor5543 »

Just a thought, but is the crankshaft sensor OK and reporting properly? If the ECU cannot 'see' what the crankshaft is doing it will not send fuel to the cylinders (even if the fuel rail has sufficient pressure).

wheeler
Posts: 4549
Joined: 21 Sep 2002, 19:07
x 195

Re: C4 Not Starting

Post by wheeler »

If you are getting a good spark & it wont even kick with starting spray you either have a timing or compression issue. Check the valve timing, just because the cams are turning doesent mean the timing belt hasn't stripped a few teeth or jumped the timing. Make sure the crank & cams are correctly aligned.
If the crank sensor was faulty I wouldn't expect to get a spark.