Turbo Issue

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

davscer
Posts: 20
Joined: 11 Sep 2019, 12:15
x 1

Turbo Issue

Post by davscer »

Hi all,

Its a 2008 2.0 HDi RHR with the Delphi Pump.

I have another problem. After replacing the injectors and the two solenoid vales, one of the turbo actuator (wastegate) and one for the air doser EGR. Its now having a turbo issue or what is controlling the turbo.

The scenario is this: In 4th gear at low rpm, i give it load to accelerate and as soon as it hits 1800 rpm, the turbo stops spooling and continues from 2000 rpm. In 5th gear the turbo stops spooling at 1700rpm and then continues and in 6th it stop spooling at 1600 rpm and it continue to spool as the rpm gets higher. This is under full load or any load. I often hear the wastegate operating on full load. I scanned it with Diagbox and no faults, just my luck. Before I pay a session for Live Data, did anyone experience this?

I checked the vacuum pipes, pumped air and i couldnt hear any leaks. Checked the if the wastegate if its holding vacuum and its fine. The wastegate rod (correct me if i am wrong) is moving freely and with vacuum applied. Could it be the turbo repeat sensor or an electrical fault or is the turbo dying?

Much help appreciated as always.

davscer
Posts: 20
Joined: 11 Sep 2019, 12:15
x 1

Re: Turbo Issue

Post by davscer »

A question about the MAF Sensor. Is it true that when the engine is running, when cold, you disconnect the MAF Sensor, the engine should cut out? This is to identify that the MAF is working correctly. Thanks.