Front Wipers

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

C5-NON
Donor 2020
Posts: 33
Joined: 26 May 2020, 21:28
x 1

Front Wipers

Post by C5-NON »

So, my front wipers are not working this morning, try the stalk but nothing happens, still spray screen wash on, so assume the stalk is OK. If one motor fails, would they both not do anything? the new price is astromomical, so really i want to change the broken one only. Any idea on finding where the problem is?

thanks

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21573
Joined: 15 Sep 2015, 19:38
x 2162

Re: Front Wipers

Post by GiveMeABreak »

Check Fuse F12 (30A) in the engine fuse box first of all. This fuse is for the front wipers.

Failing that, you will really need to get it read with Diagbox as faults with the wiper ECU and motors have a number of fault codes and yes, they do work in a master / slave relationship. If you have not had odd behaviour like the wipers going all out of synch or randomly operating one or more arms separately, then hopefully it may be just a fuse.

C5-NON
Donor 2020
Posts: 33
Joined: 26 May 2020, 21:28
x 1

Re: Front Wipers

Post by C5-NON »

thanks, is it possible to move them via diagbox? like does the driver have to move before the passenger? i.e. if the driver one is broke, will the passenger one just hit it? or will they both not operate

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21573
Joined: 15 Sep 2015, 19:38
x 2162

Re: Front Wipers

Post by GiveMeABreak »

The master ECU controls the slave ECU on the other wiper via the CAN network, so there are safeguards against them crashing into each other - so it is important to determine which one is actually at fault.

If you have Diagbox, then run a FULL global diagnostic and let me have the fault codes.

C5-NON
Donor 2020
Posts: 33
Joined: 26 May 2020, 21:28
x 1

Re: Front Wipers

Post by C5-NON »

Hi,

Fault codes on Diagbox relating to wipers are

Under BSI

F02F - No communication with the windscreen wiper ECU
F9B3 - absence of communication with the windscreen wiper ECU on the LIN

and under Engine relay unit

F9B3 - absence of communication with the windscreen wiper ECU on the LIN


I have both off the car now, opened the Driver side back up, electronics look clean, put 12v on the Motor and that works. Have not opened the Pass side, just in case its the Drivers side. how will I know?

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21573
Joined: 15 Sep 2015, 19:38
x 2162

Re: Front Wipers

Post by GiveMeABreak »

First off - check Fuse F12 in the engine fusebox as that is the one for the windscreeen wipers - a malfunction can cause that to blow.
image_2020-11-08_155928.png

C5-NON
Donor 2020
Posts: 33
Joined: 26 May 2020, 21:28
x 1

Re: Front Wipers

Post by C5-NON »

Yes did that, it’s fine with no signs of heat damage

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21573
Joined: 15 Sep 2015, 19:38
x 2162

Re: Front Wipers

Post by GiveMeABreak »

Ok, so here are the fault descriptors. There seems to be a communication fault with the LIN network. The LIN is a 12V single wire bus serving low speed - low resource requirements. The issue may be with the passenger wiper slave ECU connection to the driver's wiper master ECU, or it could be from the Driver's ECU to the engine fuse box and of course from there to the BSI - but either way the communication isn't working between the systems. So it's not just a matter of power, its the data network and will likely need LIN testing equipment to troubleshoot further.
Fault Code: F02F

Description of Fault: Absence of communication with the windscreen wiper ECU. Absence of communication with the wipers ECU (For more than 2 seconds) Via the engine fusebox.

Conditions for Fault to clear: Communication with the evolved windscreen wipe valid for more than 2 seconds (Via the engine fusebox)

Downgrade Modes whilst Fault is active: Windscreen wipe depending on the last setting. (Minimum intermittence of 4.5 seconds)

Symptoms: Windscreen wipe depending on the last setting. (Minimum intermittence of 4.5 seconds); No windscreen wash; No maintenance function

Suspect Areas: CAN BODY network; Engine fusebox; Engine fusebox LIN network; Windscreen wipers ECU
Fault Code: F9B3

Description of Fault:Absence of communication with the evolved windscreen wipe. Absence of communication with the evolved windscreen wipe

Conditions for Fault to clear: Return of communication with the evolved windscreen wipe

Downgrade Modes whilst Fault is active: Windscreen wipe in down-grade mode : Intermittent wipe (4,5 seconds)

Symptoms: Decrease of the wipe intermittence; Random activation of intermittent windscreen wipe; No wash functions; No maintenance function

Suspect Areas:Evolved windscreen wipe; Network LIN; Engine fusebox

C5-NON
Donor 2020
Posts: 33
Joined: 26 May 2020, 21:28
x 1

Re: Front Wipers

Post by C5-NON »

Would it be possible that one of the wipers ecu has failed hence no communication?

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21573
Joined: 15 Sep 2015, 19:38
x 2162

Re: Front Wipers

Post by GiveMeABreak »

That's what I was trying to convey. The wiper ECUs are interconnected in a Master / Slave relationship. Getting the correct diagnosis is important as you could end up replacing the wrong one. Reason being is because of the design of the X7 wipers, they have to be coordinated or they will start crashing into each other. So you could find it being the master ECU is faulty and therefore passenger ECU is commanded not to work, or the Passenger wiper ECU is not talking to the Driver wiper ECU so it stops operation.

When mine went (and I'm sorry but I can't remember which one they replaced now) I had intermittent issues with both wipers and sometimes one wiper would lift vertically and remain, then it would park, then the other side would move on its own without the other one etc. But whichever one it was, the whole thing was replaced under warranty.

There was a recall for the driver's windscreen motor, but this supposedly only affected vehicles built between 10/03/2009 to 19/06/2009. Mine was built on the 18th, so was probably affected in this recall and was probably the driver's one thinking about it.

C5-NON
Donor 2020
Posts: 33
Joined: 26 May 2020, 21:28
x 1

Re: Front Wipers

Post by C5-NON »

Hi, ive tried x2 replacement wiper motors (used, but breaker assures they work), hence the auto electrician, thinks fuse box fault. Do you know the part number for the under bonnet fuse box?

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21573
Joined: 15 Sep 2015, 19:38
x 2162

Re: Front Wipers

Post by GiveMeABreak »

Sure, the engine fusebox is part 9807028580 for your specific Tourer. Item (1) below, no coding needed, but do follow the BSI Reset / Battery Disconnect / Reconnect Procedure when removing and fitting.
C5 Non Fusebox.PNG

C5-NON
Donor 2020
Posts: 33
Joined: 26 May 2020, 21:28
x 1

Re: Front Wipers

Post by C5-NON »

Hi, thanks, the one on the car has the number 9675877980. Is the one you mentioned a newer part no?

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21573
Joined: 15 Sep 2015, 19:38
x 2162

Re: Front Wipers

Post by GiveMeABreak »

Yes, the number I quoted you is the only fuse box they supply now for the X7 and is the latest part number - all the older fuse boxes have been replaced with this one for the X7. If you are looking for a second hand one then by all means search for the same part number as yours - as this was an earlier fuse box part number.

C5-NON
Donor 2020
Posts: 33
Joined: 26 May 2020, 21:28
x 1

Re: Front Wipers

Post by C5-NON »

That’s great, thanks. Got to love French electrics.