C5 2005 Exclusive Ignition Issue

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

solcutter
Posts: 5
Joined: 26 Oct 2020, 10:20

C5 2005 Exclusive Ignition Issue

Post by solcutter »

Hi all I'm new to this forum,

I'm hoping someone can help me with my ignition issue,

I just purchased a second hand 2005 C5 Exclusive, I love the car, everything electronic aside from the parking sensors worked on it when I got it about 5 days ago, which is a lot if you've had one you will know.

Two days ago I took my brother for a ride in it to show it off to him, he's always been a fan of Peugeot's & Citroen.

After we came back, I noticed that when I turned the car off I could hear the cd player whirring around as it had the Sat Nav disc in it, I also noticed the lane warning light was still showing on the button on the centre controls.

I thought this was odd as the ignition was turned off & they key was out also the display screen for the sat nav / radio was still on, I turned it to dark mode, went in my house, came out next morning & the battery was flat.

The best way I can describe it is the ignition is not turning everything off completely.

I have searched Google & learnt about the BSI & how to reset / reboot it, I have tried that & now my drivers window doesn't shut properly either, it goes up an inch at a time when I try to close it.

I'm not sure if I've done the reset wrong I have tried three times but it doesn't seem to make any difference.

Any advice would be really appreciated, at the moment I'm having to disconnect the battery so it doesn't drain as I need the car for work daily

User avatar
xantia_v6
Forum Admin Team
Posts: 7535
Joined: 09 Nov 2005, 23:03
x 430

Re: C5 2005 Exclusive Ignition Issue

Post by xantia_v6 »

The window limits need to be reset after battery disconnection, by inching them up until they hit the top stops, this is normal.

If your accessories are still not turning off, then you do have a problem, perhaps a faulty BSI, but I would recommend getting the fault codes read, as they may give a definitive diagnosis (or they may not...)

solcutter
Posts: 5
Joined: 26 Oct 2020, 10:20

Re: C5 2005 Exclusive Ignition Issue

Post by solcutter »

xantia_v6 wrote:
27 Oct 2020, 08:48
The window limits need to be reset after battery disconnection, by inching them up until they hit the top stops, this is normal.

If your accessories are still not turning off, then you do have a problem, perhaps a faulty BSI, but I would recommend getting the fault codes read, as they may give a definitive diagnosis (or they may not...)
Thanks for your reply, I have hooked up my OBD reader & the car is showing no fault codes at all

solcutter
Posts: 5
Joined: 26 Oct 2020, 10:20

Re: C5 2005 Exclusive Ignition Issue

Post by solcutter »

I have sort of fixed the window it goes down ok now but still inches up when I close it, I have tried several times & also tried the 10 second button hold to fix it, I'm not too bothered about the window just the battery drain issue as I'm worried it might flatten the battery if I leave it on while at work

wheeler
Posts: 4383
Joined: 21 Sep 2002, 19:07
x 164

Re: C5 2005 Exclusive Ignition Issue

Post by wheeler »

Are there any non original electrical accessories fitted to the car? Eg handsfree kit, aftermarket radio etc.
Or have you fitted anything else to the car since youve had it?

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21573
Joined: 15 Sep 2015, 19:38
x 2162

Re: C5 2005 Exclusive Ignition Issue

Post by GiveMeABreak »

It is perfectly normal for the Head unit to continue making a noise as you describe after switching the ignition off. I suspect you have the RT3 / 4 Navidrive system and this noise will be the internal cooling fan that remains on to cool the system down, but it can also continue spinning the CD-ROM. You can eject the navigation CD-ROM from the head unit before switching the ignition off to lessen this, but the fan will continue to run for a while as there is very little room in these head units for air to circulate. It was the same on my MK II with Navidrive.

As for the anti pinch - you must edge the windows up manually, a little at a time using the button until it reached the closed position and then only hold for a few seconds until you hear a faint click then release - you don't hold it for 10 seconds.

solcutter
Posts: 5
Joined: 26 Oct 2020, 10:20

Re: C5 2005 Exclusive Ignition Issue

Post by solcutter »

wheeler wrote:
27 Oct 2020, 10:53
Are there any non original electrical accessories fitted to the car? Eg handsfree kit, aftermarket radio etc.
Or have you fitted anything else to the car since youve had it?
The issue has now gone for the time being, but no nothing fitted to the car

solcutter
Posts: 5
Joined: 26 Oct 2020, 10:20

Re: C5 2005 Exclusive Ignition Issue

Post by solcutter »

GiveMeABreak wrote:
27 Oct 2020, 11:49
It is perfectly normal for the Head unit to continue making a noise as you describe after switching the ignition off. I suspect you have the RT3 / 4 Navidrive system and this noise will be the internal cooling fan that remains on to cool the system down, but it can also continue spinning the CD-ROM. You can eject the navigation CD-ROM from the head unit before switching the ignition off to lessen this, but the fan will continue to run for a while as there is very little room in these head units for air to circulate. It was the same on my MK II with Navidrive.

As for the anti pinch - you must edge the windows up manually, a little at a time using the button until it reached the closed position and then only hold for a few seconds until you hear a faint click then release - you don't hold it for 10 seconds.
Yes it is an RT3, it wasn't just the head unit making internal noise it was powered on fully, the cd doesn't spin after the ignition is turned off either. The window is working now, I read on more than one forum to hold for ten seconds to reset the position & it seems to have worked

The issues have now gone anyway, I have left it sat all day at work, the car started fine with no battery drain, the one light on my control buttons that was staying on which was the lane warning light, is now turning off when I turn the ignition off, which is the only indication when it was playing up that the ignition & other systems were still sucking juice from the battery, personally I think it could have been the wet weather messing with a connection somewhere as we've just had a lot of rain, thanks for your reply though