Peugeot 308 SW 1.2 2015 Engine fan not working

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

normanbates
Posts: 3
Joined: 21 Sep 2020, 16:29

Peugeot 308 SW 1.2 2015 Engine fan not working

Post by normanbates »

My engine fan stopped working with a message about enginge fault coming up on the screen.
Checked with Diagbox and have fault codes P0691 & P0693(low and high speed). Checked fuses and found one 5 amp that was faulty.
Replaced the fuse and fans came on, i guess the enigne was still warm and thats why the fan started.
Started the car and the error message was gone and my AC now came on and blew cold air.
At the next start the message came back and the fuse was blown again. Replaced it again and the fans came on for about 5 secs before fuse popped again.
Checked with multimeter from the fuse to ground and had about 30 ohms. I unplugged the fan and the two connectors at the fan relay, but fuse stil pops after afew seconds.
Anyone who knows what else i using that fuse that could make i go or maybe someone allready knows what the problem is or can point me in some direction?

Attached a picture of fusebox with the fuse in question marked.
Fuse.PNG
Fuse.PNG (54.42 KiB) Viewed 70 times

User avatar
xantia_v6
Forum Admin Team
Posts: 7470
Joined: 09 Nov 2005, 23:03
x 419

Re: Peugeot 308 SW 1.2 2015 Engine fan not working

Post by xantia_v6 »

You really need to get a list of all the items that get power through that fuse. It is unlikely that the fan motor is powered by a 5A fuse, but it probably does power the fan controller and other items.

normanbates
Posts: 3
Joined: 21 Sep 2020, 16:29

Re: Peugeot 308 SW 1.2 2015 Engine fan not working

Post by normanbates »

Yes, something else is using this fuse too which makes it blow, probably some sensor or controller i dont know.
The fan is as you say not powered itself by this fuse, it has a 30 or 40 amp fuse (dont quite remember, maybe even a bigger one).

User avatar
xantia_v6
Forum Admin Team
Posts: 7470
Joined: 09 Nov 2005, 23:03
x 419

Re: Peugeot 308 SW 1.2 2015 Engine fan not working

Post by xantia_v6 »

I think that the fuse you have marked is F21, but Peugeot seem to not mention it in the handbook. I don't have any wiring diagrams available at present, but maybe someone else can look it up.

On the earlier T7 model, that fuse powered the turbo cooling pump which often failed, causing the fuse to blow.

normanbates
Posts: 3
Joined: 21 Sep 2020, 16:29

Re: Peugeot 308 SW 1.2 2015 Engine fan not working

Post by normanbates »

I have checked now and in the fusebox its marked as F12, but nothing in the handbook either way.