I Phone issues with MyWay / WIPNAV

This unit is the MyWay system, also referred to as RNEG, made by Harman Becker.
Main Features: Also referred to as RNEG, the MyWay colour satellite navigation system, has SD card, integrated European mapping, live trafic information, voice guidance and graphics in 2D or aerial perspective & it features a Bluetooth® system (Bluetooth phone compatibility only - no Bluetooth Audio Streaming).

Moderator: RichardW

admiral51
Donor 2021
Posts: 2339
Joined: 24 May 2007, 10:11
x 297

I Phone issues with MyWay / WIPNAV

Post by admiral51 »

Not sure where to post this so if it gets moved to the right section =D>
Vehicle is my C5 X7 vin in my sig and i am 99.99% sure the system is a MyWay / WIPNAV.

Software/firmware is rneg_D_R20ter_R20.07

So onto my issue.
If i connect any android phone to the car when an incoming call pops up i get the callers name and below i get the phone number, and i have connected 3 android phones with no issues.
However when connecting an iPhone 6s which is my better halfs phone we get only the phone number and not the callers name.
We can dial through the phone book and call a number by name yet when we do the reverse we only get the number not the name.
When we go through the call log it shows the name not number dialled and below that the number that called but no name :? :?
Is it a software issue for the head unit or is something we are not doing on the iPhone itself?
Thanks in advance

Colin
Last edited by GiveMeABreak on 05 Sep 2020, 20:44, edited 1 time in total.
Reason: Moved to the MyWay Forum
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25415
Joined: 15 Sep 2015, 19:38
x 2831

Re: I Phone issues with MyWay / WIPNAV

Post by GiveMeABreak »

Colin, each time you pair another Bluetooth phone, it can take a while for the new phone’s address book to synchronise with the MyWay (and assuming you have given permission on the iPhone).

Of course, switching the car off will interrupt this process each time, and it will start again until it is synchronised.
admiral51
Donor 2021
Posts: 2339
Joined: 24 May 2007, 10:11
x 297

Re: I Phone issues with MyWay / WIPNAV

Post by admiral51 »

Hi Marc
It has been like that with the iphone ever since we got the car nearly 10 months ago, regardless of how long we have it connected, even drove for 3 hours and still the same.
Sync has been set on the iphone bluetooth settings when it putting in the pair code etc and it shows up on the phone as sync all contacts/groups/favourites so no idea what to do next, SWMBO doesn't want a new phone and she is keeping the car and all i get is aggro about the phone lol

Colin
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25415
Joined: 15 Sep 2015, 19:38
x 2831

Re: I Phone issues with MyWay / WIPNAV

Post by GiveMeABreak »

Ok, I will have a look to see if any of the firmware updates mentions anything about fixing this issue, as you are quite a few versions behind.
admiral51
Donor 2021
Posts: 2339
Joined: 24 May 2007, 10:11
x 297

Re: I Phone issues with MyWay / WIPNAV

Post by admiral51 »

Cheers Marc
I did try before to update the firmware, didn't go well, will need to try again i think, upgrade 1 at time IIRC

Colin
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25415
Joined: 15 Sep 2015, 19:38
x 2831

Re: I Phone issues with MyWay / WIPNAV

Post by GiveMeABreak »

These are rough translations of the various firmware releases since your version Colin. I have most of these if you need them - update needs to be done via SD card as CD can be unreliable (dust / laser lens dirty etc.)

Official Change Log RNEG r50b_50.03: (Latest and Last Update)

- Random restart at the beginning of a route calculation
- Several bugs in the Bluetooth (incompatibility with some phones, Bluetooth pairing loss at the beginning of a phone call, poor sound quality)
- The message "unknown" appears instead of the name of the caller when a call comes in
- Incorrect calculation of radar speed limit for vehicles with speedometer in miles
- (only in Latin America) Navigation (RNEG) starts the "demo mode" with activated navigation
- In navigation mode: Cursor frozen in GPS map. GPS adjustment cursor position relative to actual vehicle position
Estimated time of arrival is overestimated or underestimated during route guidance
- accidental loss of audio settings after starting the engine
- random sound loss after starting the engine
- Cracking in the speaker after starting the vehicle
- Random yellowing in the multifunction display
- accidental loss of time and altitude
- Call list not visible in the multifunction display


Official Change Log RNEG r40b_4003:

-Different Bluetooth interference (incompatibility with certain phones, loss of Bluetooth Twinning at the beginning of a call, poor sound quality)
- "UNKNOWN" is displayed instead of the name of the caller when a call is received
-Under-estimate of the radar speeds for vehicles with the speed unit in miles
-In Latin America only, restart the audio navigation system (RNEG) after a request for navigation in "demo" mode
-In navigation mode: put cursor on the GPS mapping, The cursor on the GPS mapping does not reflect the actual position of the vehicle
-Arrival time is either over-or under-estimated when navigating.
-Random loss of audio settings after starting the engine
-Random loss of audio sound after starting the engine
Interference in the speakers after starting the engine
- Multifunction screen at random yellow
-Random loss of time and altitude
- The telephone directory or the history of the calls of the radio navigation system RNEG is no longer visible on the multifunction screen.


Official Change Log RNEG r33b_3309:

Here is a quote from another forum for the purpose of changes.
- new Boot logo
- System starts up much faster
- Sound quality has improved audibly
- Navigating through the menu is much faster
- Switching the different modes is much faster
- Phone connection much more stable
- Navigating through the phone book is faster
- BT shuts off after some time if no device is paired
- GPS fix is faster
admiral51
Donor 2021
Posts: 2339
Joined: 24 May 2007, 10:11
x 297

Re: I Phone issues with MyWay / WIPNAV

Post by admiral51 »

Thanks Marc does look like most of those updates include stuff that should help the system itself perform better.
If i can trouble you for the updates i will work through them 1 by 1 until i get to the last and latest update, really did not realise the firmware was that far out of date.
I have re read your sticky about doing the firmware updates and as you know me and tech are not best of bedfellows so if you are not going offline this weekend ( no worries if you want to run and hide :) ) i will try to work through them lol

Colin
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25415
Joined: 15 Sep 2015, 19:38
x 2831

Re: I Phone issues with MyWay / WIPNAV

Post by GiveMeABreak »

No worries, I'll get you some links in the morning as the back has gone from the mowing marathon this afternoon :-D
admiral51
Donor 2021
Posts: 2339
Joined: 24 May 2007, 10:11
x 297

Re: I Phone issues with MyWay / WIPNAV

Post by admiral51 »

Hi Marc
Thanks for the links in the PM.
However....................................... :)

Downloaded and extracted to the first of them R29a to the SDHC card and i have a folder with the number of the update and the 2 files Headunit and HBUPDATE.Def on the card but the headunit does not recognise it.
What have i done wrong :(
Colin
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25415
Joined: 15 Sep 2015, 19:38
x 2831

Re: I Phone issues with MyWay / WIPNAV

Post by GiveMeABreak »

Ok, so your problem is what you have copied onto the SD card.

Sometimes when you use a utility programme like 7 Zip or other to extract the files - it suggests and sometimes creates a folder (typically the name of the archived file like 'RNEG_R29a_29.01') and extracts the files into this folder. If this has happened, then the MyWay system will not recognise that this is an update as it expects the correct files to be in the root of the SD card.

A couple of warnings first:

A) Always switch off your mobile phone (literally power it off) as if this has been a previously connected phone with the MyWay and a call comes in or it picks up the phone, it can interfere with the upgrade.
B) Get comfortable before starting and don't press any switches or buttons or open doors or windows while performing the update - any of these can cause multiplexed signals from the BSI and you don't want anything interfering with a firmware update.

1) So I suggest you create a folder on your desktop and call it Temp.
2) Make sure your SD card is empty.
3) Then locate the archived file (RNEG_R29a_29.01.rar) and right-click on it and select the 7 Zip slide out menu.
4) There will be lots of options; choose the 'Extract Files...' option, then browse to the 'Temp' folder on the desktop as shown in this example and make sure you have the 'Eliminate Duplication of Root Folder' option checked!
MyWay B.PNG
5) When you open the Temp folder, you should have just the following in there:
myway.PNG
myway.PNG (5.27 KiB) Viewed 422 times
6) Now just select both the HEADUNIT folder and the HBUPDATE.DEF file and copy these over to the SD card.
7) Insert the SD card into the MyWay, start the car and allow at least 30 minutes with car running to update.
8) After it has completed, check everything is ok before repeating the procedure with the next update.

PS - I strongly suggest you apply one upgrade at a time, rather than going straight to the latest update - because if anything goes :bouncy: up, then you always have a later update to use (as you can't downgrade the firmware).

Any issues let me know. :-D
admiral51
Donor 2021
Posts: 2339
Joined: 24 May 2007, 10:11
x 297

Re: I Phone issues with MyWay / WIPNAV

Post by admiral51 »

Thanks Marc
First step completed i now have only the HEADUNIT folder and HBUPDATE.DEF file on the SD card :)
Will get comfortable later today and see what happens

Colin
admiral51
Donor 2021
Posts: 2339
Joined: 24 May 2007, 10:11
x 297

Re: I Phone issues with MyWay / WIPNAV

Post by admiral51 »

All sorted now thanks to the help and advice from Marc yet again. =D>
Updated firmware to the latest version now, only took a couple of hours 1 by 1 and everything is working correctly now and for once it did not go :bouncy: up

So SWMBO is happy and i get some brownie points for the weekend of Football and F1 , bet they last for about as long as it takes to post this :rofl2:

Colin
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25415
Joined: 15 Sep 2015, 19:38
x 2831

Re: I Phone issues with MyWay / WIPNAV

Post by GiveMeABreak »

Well, you should of egged it out a bit and did one upgrade each weekend to ensure additional time in the man cave watching F1 or the footie!
admiral51
Donor 2021
Posts: 2339
Joined: 24 May 2007, 10:11
x 297

Re: I Phone issues with MyWay / WIPNAV

Post by admiral51 »

Okay so my cars are giving me a kicking so here we go again ...........

After best part of 12 months with no complaints now i have another issue.

All phones connect and sync correctly with the head unit however when receiving a call i get the ring tone through the speakers but cannot hear the caller once answered, nor can the caller hear me.
When i dial out i do not even get the ringing sound and the same issue neither can hear each other.

Yet to do a Diagbox session or BSI reset but can anyone shed some light on what maybe going on.

Colin
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25415
Joined: 15 Sep 2015, 19:38
x 2831

Re: I Phone issues with MyWay / WIPNAV

Post by GiveMeABreak »

I doubt that will help Colin, it's more likely the Head Unit or the phone / phone software. I'm not sure which C5 we are talking about as you have different systems in each, but have you updated the smartphone software lately? Sometimes this can affect the operation / bluetooth connections.

So first off, I would both unpair AND delete the phone from the Head Unit and also delete the pairing from the Smart phone too under the bluetooth settings.

Reboot the phone and switch the vehicle ignition off and leave it for 10 minutes.

The try re-pairing one phone again from scratch and see if you can establish correct operation again. Bear in mind it will take some time of the Head Unit being connected before contacts will synchronise again, so just try and dial manually for the test.