Noisy engine after timing belt replacement

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

JinX99
Posts: 2
Joined: 25 Jul 2020, 22:39

Noisy engine after timing belt replacement

Post by JinX99 »

Hi, new to the forum,

I put my van in for a new timing belt / water pump kit. It's a 1.6 HDi 2010 Citroen Berlingo, 92,000 miles
Kit was a Dayco. They also changed the AUX belt.

Within 5 mins of driving it, I noticed engine sounded different and louder, like something whirring/scraping rotational noise, hard to describe the noise...

Then 20 mins after the red oil pressure light came on, with beeping and STOP light on the dash.
I let the engine cool for about an hour... The warning sign has not returned since after 30 mins of driving.

But I am now worried the engine is damaged i.e. What would cause the oil pressure light to come on after a timing belt change?

User avatar
white exec
Moderating Team
Posts: 6288
Joined: 21 Dec 2015, 13:46
x 1060

Re: Noisy engine after timing belt replacement

Post by white exec »

That's serious, and the car should not be driven.
Any sign of an oil leak?
Contact the garage/workshop that did the work, and discuss.
They should trailer the car back to the workshop, if necessary.

JinX99
Posts: 2
Joined: 25 Jul 2020, 22:39

Re: Noisy engine after timing belt replacement

Post by JinX99 »

Hi,

Thanks for the post

No sign of an oil leak and level is correct.
However the oil does seem a bit thick/black.

I spoke to another mechanic friend and he reckons its a coincidence the oil pressure light came on and recommended I change the oil.

The noise has gone so bit of a mystery...

I will change the oil / service, may aswell take the sump off while I am at it