Forum scheduled maintenance 17/07/2020 - 31/07/2020 - Completed

Forum News, Announcements and any issues you're having with the forum

Moderator: myglaren

User avatar
xantia_v6
Forum Admin Team
Posts: 7908
Joined: 09 Nov 2005, 23:03
x 512

Forum scheduled maintenance 17/07/2020 - 31/07/2020 - Completed

Post by xantia_v6 »

I will be installing and testing a different web server package on this forum. There are several possible configurations to use, and I intend to test each one for a few days to compare real-world performance.

There should be little difference detectable by normal users, perhaps the forum pages will load a little faster or slower, but there should be more significant change in the server CPU load visible to me.

To make the configuration changes, I will need to take the forum off-line for up to 2 hours at a time on several occasions, but I will usually do this between 11:30 pm and 3:00 am UK time.

If a particular configuration seems to cause issues for users, I should be able to revert to a working configuration quite quickly.

If you notice a significant change or problem with server performance dring this period, please report it by replying here.
User avatar
xantia_v6
Forum Admin Team
Posts: 7908
Joined: 09 Nov 2005, 23:03
x 512

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by xantia_v6 »

I have made the first set of changes to the server configuration. The forum should be 98% functional.

I am aware of a few issues which I will sort out as soon as I can:
I am not aware of any issues with the current configuration.

Report anything else here.
User avatar
NewcastleFalcon
Posts: 17286
Joined: 25 Feb 2009, 11:40
x 1883

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by NewcastleFalcon »

Really slow on moving from page to page just now and in the last 10 minutes or so

Seems to have perked up a bit now

regards Neil
User avatar
xantia_v6
Forum Admin Team
Posts: 7908
Joined: 09 Nov 2005, 23:03
x 512

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by xantia_v6 »

I have noticed that slow page loading also, but it is not consistent. I am investigating.

A few more reports would be handy. It is possible that it is a one-off thing related to reloading the server configuration While configuring the site I need to reload the configuration quite often, but I will leave it alone for a few hours now.
User avatar
NewcastleFalcon
Posts: 17286
Joined: 25 Feb 2009, 11:40
x 1883

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by NewcastleFalcon »

xantia_v6 wrote:
15 Jul 2020, 09:02
I have noticed that slow page loading also, but it is not consistent. I am investigating.
Not consistent is the right description. one page took over 100 seconds to action on a post then navigating to this page to report just normal. See how long this post takes to complete and I'll edit it in

about 3 secs to refresh after posting pretty much normal


Regards Neil
User avatar
bobins
Donor 2021
Posts: 4170
Joined: 05 Jul 2012, 18:07
x 1338

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by bobins »

I can echo what Neil's said above. I've noticed it on both W10/ Firefox and 2 different Androids/Chrome. I wouldn't like to say that it's the forum software doing it though.
User avatar
xantia_v6
Forum Admin Team
Posts: 7908
Joined: 09 Nov 2005, 23:03
x 512

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by xantia_v6 »

I think that the problem is (was?) due to a deadlocking in the server. I have increased the php process count limit, lets see if that helps.
User avatar
Paul-R
Donor 2020
Posts: 5443
Joined: 07 May 2009, 16:24
x 804

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by Paul-R »

I can't say I've noticed any difference so far but then there aren't that many new posts for me to look at. This will be my first post so we'll see how that goes...

EDIT
Couldn't see any difference in the length of time taken to accept the post.

FURTHER EDIT
Posting the edit took definitely longer though.

EVEN FURTHER EDIT
Ha! The further edit didn't take long so I think that it may have been "just one of those things" as I've had long waits in the past anyway,
Last edited by Paul-R on 15 Jul 2020, 10:34, edited 1 time in total.
User avatar
xantia_v6
Forum Admin Team
Posts: 7908
Joined: 09 Nov 2005, 23:03
x 512

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by xantia_v6 »

I don't expect that users should see any big change in performance, maybe a little shaved off page load times. I can report though that the server CPU load has reduced to almost half the previous average value.

There are several more parameters that can be tuned to improve the site performance, but I will leave it more or less as it is for a couple of days to get a baseline and check stability.
User avatar
NewcastleFalcon
Posts: 17286
Joined: 25 Feb 2009, 11:40
x 1883

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by NewcastleFalcon »

still doing the 100 second page load up from time to time on just selecting a topic page to view.

Then it goes back to pretty much what i usually expect.

Regards Neil
User avatar
GiveMeABreak
Forum Admin Team
Posts: 26065
Joined: 15 Sep 2015, 19:38
x 2992

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by GiveMeABreak »

Mike, I've just finished submitting a post at 11:05 AM with a table and a couple of images, and not only did it take ages to submit, but on preview one attachment was not showing. Then I realised it was still processing the last preview so was lagging behind. It took 3 attempts to submit it and now finally the post has gone through with everything:

viewtopic.php?&t=65822&p=650881#p650881

Edit: 23 seconds to submit this post
User avatar
xantia_v6
Forum Admin Team
Posts: 7908
Joined: 09 Nov 2005, 23:03
x 512

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by xantia_v6 »

I have reverted back to the old server software for now, so performance should be back to normal. I will have another attempt at understanding the problem later.
User avatar
myglaren
Forum Admin Team
Posts: 20456
Joined: 02 Mar 2008, 14:30
x 1737

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by myglaren »

Most page loads have been fine but one did take a couple of minutes. As usual I suspected my broadband connection but other sites seemed unaffected.
I had had some dropouts on the broadband earlier this morning.
User avatar
NewcastleFalcon
Posts: 17286
Joined: 25 Feb 2009, 11:40
x 1883

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by NewcastleFalcon »

Couple of hundred seconds or so page look ups.

I tend to click on the last page number on a topic shown, so on the electric vehicles spotting thread it was about page 84 and Simon's Blog 148 both took a long time to load up.

Is it a long thread thing which provokes the long look ups?

Edit....pretty instantaneous on doing the same thing again....just now


Regards Neil
User avatar
white exec
Moderating Team
Posts: 7387
Joined: 21 Dec 2015, 13:46
x 1448

Re: Forum scheduled maintenance 17/07/2020 - 31/07/2020

Post by white exec »

YouTube button has disappeared.