Dispatch 2.0 hdi problem

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

John224
Posts: 6
Joined: 10 Jun 2020, 17:52

Dispatch 2.0 hdi problem

Post by John224 »

Hi i am a new member looking for assistance, i have a 2009 citroen dispatch 2.0 hdi l1h1 van. Three month ago i was driving home when engine management light came on, anti pollution filter fault displayed and van lost all power and stalled. I got van started again but loads of grey smoke from exhaust and whirring noise from engine no power and running very irratic, took me three hours to drive 6 mile. Van wouldn't start the following day, van has now been stood for three month. Does anyone have any experience of the same problem and a solution. Any help and advice would be greatly appreciated. John

Hell Razor5543
Donor 2021
Posts: 11664
Joined: 01 Apr 2012, 09:47
x 1394

Re: Dispatch 2.0 hdi problem

Post by Hell Razor5543 »

Hi, and :welc: to the Forum. While I cannot offer you any meaningful advise wait for a while, and somebody will come along with useful knowledge.

User avatar
moizeau
Donor 2020
Posts: 1113
Joined: 12 Jan 2015, 17:08
x 153

Re: Dispatch 2.0 hdi problem

Post by moizeau »

Could be a number of things, unfortunately these days it'll need plugging in to narrow down the issue. Not a cheap reader though, there is a list somewhere on here with people with Diagbox. You need that or a pro grade reader or the dealer.

Hell Razor5543
Donor 2021
Posts: 11664
Joined: 01 Apr 2012, 09:47
x 1394

Re: Dispatch 2.0 hdi problem

Post by Hell Razor5543 »

As Pete says, you will need to get the error codes from the van, and this will need to be done with a serious code reader, and not a generic OBD reader. Fortunately there are Forum members with such kit, and are willing to help out. Here is the list, but not all of the members are still active, so they may not respond;

https://www.frenchcarforum.co.uk/forum/ ... hp?t=56452

John224
Posts: 6
Joined: 10 Jun 2020, 17:52

Re: Dispatch 2.0 hdi problem

Post by John224 »

Thanks think thats going to be my first port of call getting a diagnostic done👍

John224
Posts: 6
Joined: 10 Jun 2020, 17:52

Re: Dispatch 2.0 hdi problem

Post by John224 »

Hi again eventually had codes read and codes p131 and p0402 are showing any help would be appreciated

User avatar
GiveMeABreak
Forum Admin Team
Posts: 24390
Joined: 15 Sep 2015, 19:38
x 2668

Re: Dispatch 2.0 hdi problem

Post by GiveMeABreak »

You're a digit short somewhere in 'P131' and I'll need your VIN to relate the codes directly to the engine ECU installed on your vehicle.

User avatar
moizeau
Donor 2020
Posts: 1113
Joined: 12 Jan 2015, 17:08
x 153

Re: Dispatch 2.0 hdi problem

Post by moizeau »

Bet that's p1351, HDi in a Cit....

John224
Posts: 6
Joined: 10 Jun 2020, 17:52

Re: Dispatch 2.0 hdi problem

Post by John224 »

Sorry yeah it's p1351 and p0462

John224
Posts: 6
Joined: 10 Jun 2020, 17:52

Re: Dispatch 2.0 hdi problem

Post by John224 »

And vin is VF7**************[VIN obfuscated, can be read by forum staff]

User avatar
moizeau
Donor 2020
Posts: 1113
Joined: 12 Jan 2015, 17:08
x 153

Re: Dispatch 2.0 hdi problem

Post by moizeau »

Ignore the 1351, it's a 'factory default', glow plugs or relay, not needed and most have it, 462 I'll leave A N Other

John224
Posts: 6
Joined: 10 Jun 2020, 17:52

Re: Dispatch 2.0 hdi problem

Post by John224 »

Yeah I kinda guessed the 131 was common reading through some forums. The 462 points towards the egr or some sort of exhaust problem, but that wouldn't explain the whirring noise. I was thinking possibly Westgate valve failure and too much pressure on the turbo. Was hoping someone had a easier solution as it looks a pig to get to