Dispatch 2.0 hdi problem

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

John224
Posts: 2
Joined: 10 Jun 2020, 17:52

Dispatch 2.0 hdi problem

Unread post by John224 »

Hi i am a new member looking for assistance, i have a 2009 citroen dispatch 2.0 hdi l1h1 van. Three month ago i was driving home when engine management light came on, anti pollution filter fault displayed and van lost all power and stalled. I got van started again but loads of grey smoke from exhaust and whirring noise from engine no power and running very irratic, took me three hours to drive 6 mile. Van wouldn't start the following day, van has now been stood for three month. Does anyone have any experience of the same problem and a solution. Any help and advice would be greatly appreciated. John

Hell Razor5543
NOT Alistair or Simon
Posts: 10339
Joined: 01 Apr 2012, 09:47
x 943

Re: Dispatch 2.0 hdi problem

Unread post by Hell Razor5543 »

Hi, and :welc: to the Forum. While I cannot offer you any meaningful advise wait for a while, and somebody will come along with useful knowledge.

moizeau
Donor 2020
Posts: 950
Joined: 12 Jan 2015, 17:08
x 127

Re: Dispatch 2.0 hdi problem

Unread post by moizeau »

Could be a number of things, unfortunately these days it'll need plugging in to narrow down the issue. Not a cheap reader though, there is a list somewhere on here with people with Diagbox. You need that or a pro grade reader or the dealer.

Hell Razor5543
NOT Alistair or Simon
Posts: 10339
Joined: 01 Apr 2012, 09:47
x 943

Re: Dispatch 2.0 hdi problem

Unread post by Hell Razor5543 »

As Pete says, you will need to get the error codes from the van, and this will need to be done with a serious code reader, and not a generic OBD reader. Fortunately there are Forum members with such kit, and are willing to help out. Here is the list, but not all of the members are still active, so they may not respond;

https://www.frenchcarforum.co.uk/forum/ ... hp?t=56452

John224
Posts: 2
Joined: 10 Jun 2020, 17:52

Re: Dispatch 2.0 hdi problem

Unread post by John224 »

Thanks think thats going to be my first port of call getting a diagnostic done👍