C5 I phase 2 EDC16 CP39 2.2 liter 170 HP motor pressure sensor reads always 3000 mbar

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

karlm
Posts: 3
Joined: 03 Jun 2020, 11:29

C5 I phase 2 EDC16 CP39 2.2 liter 170 HP motor pressure sensor reads always 3000 mbar

Unread post by karlm »

Hi,
I have this C5 from 2006, so the facelift, with the 170 HP engine and the EDC16 CP39 injection unit.
The problem ist, that the air pressure sensor behind the second turbo, a 1920HL, part 1390 in the schematics, always shows 3000 mbar which cannot be correct. The sensor itself is working I tested it on the desk by supplying 5 V to it and it returns 1,4 V which corresponds to ambient air pressure.
Everything else works fine, there is no error in Lexia for the injection system.

I am running out of ideas what to check. Any idea who I can get a reading there? I checked the cabling between sensor and EDC and it seems fine.

In Lexia, there is a software update for the EDC16 CP39 in the list of files. The installed software on the injection unit is 05.07 and the one available is 06.01. Is it possible to update this with the Lexia? In the description it is mentioned that it resolves some problems with the switching from turbo 1 to turbo 2 and some problems with the diagnostics for the EGR.

Thanks
Philipp

User avatar
xantia_v6
Forum Admin Team
Posts: 7293
Joined: 09 Nov 2005, 23:03
x 390

Re: C5 I phase 2 EDC16 CP39 2.2 liter 170 HP motor pressure sensor reads always 3000 mbar

Unread post by xantia_v6 »

If everything is working fine with no fault codes, then it may just be a bug in the diagnostics software that is not reading the sensor value correctly.

karlm
Posts: 3
Joined: 03 Jun 2020, 11:29

Re: C5 I phase 2 EDC16 CP39 2.2 liter 170 HP motor pressure sensor reads always 3000 mbar

Unread post by karlm »

Yes, I was thinking so as well. But how to be sure?
Well, the consumption is quite high, the car uses 7.5 liters per 100 km and it produces quite a lot of coke in the EGR. This looks to me like having to much fuel injected due to the 3000 maybe.
Someone found on his car that he has Version 6.4 installed. So I have 5.7, there is for sure a 6.1, and also a 6.4. I wonder if there is any changelog.
I also wonder, if I run the update and it runs though, should the ECU work then? Or does it need to be initialized or something?

karlm
Posts: 3
Joined: 03 Jun 2020, 11:29

Re: C5 I phase 2 EDC16 CP39 2.2 liter 170 HP motor pressure sensor reads always 3000 mbar

Unread post by karlm »

So, apparantly it was a bug in the software. I had 5.7 on the ECU, now got upgraded to 6.4. Now the values show correctly. If the car also runs better I doubt. I think it was a pure diagnostic problem.