Oh no ! Xantia failed me this morning 🤪

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

zs&tas
Posts: 186
Joined: 18 Mar 2013, 17:07
x 3

Oh no ! Xantia failed me this morning 🤪

Unread post by zs&tas »

Good morning 🌞 xantias been running fine , this morning all ok for five minutes then starts missing and has glowing cat , very impressive actually , like a race car 😂 shame it's just 1.8 8v lol
The search begins when I finish work 🙏
I will start with checking if it is just one cylinder or more ... Already ordered a coil just incase , they are not expensive anyway .

zs&tas
Posts: 186
Joined: 18 Mar 2013, 17:07
x 3

Re: Oh no ! Xantia failed me this morning 🤪

Unread post by zs&tas »

Does somebody have the coil test values ?

User avatar
GiveMeABreak
Forum Admin Team
Posts: 19909
Joined: 15 Sep 2015, 19:38
x 1943

Re: Oh no ! Xantia failed me this morning 🤪

Unread post by GiveMeABreak »

Have a look in the mechanics handbook we've put up on the site:

viewtopic.php?f=3&t=61218&p=590278#p590278

Although its from 2001, the 1.8i 8 valve was still available on the S2 and that is covered in the manual. Maybe you'll find what you need there.

zs&tas
Posts: 186
Joined: 18 Mar 2013, 17:07
x 3

Re: Oh no ! Xantia failed me this morning 🤪

Unread post by zs&tas »

Thanks , I will look, I really thought I'd found the problem , a really bad ht lead but after a rebuild and testing good I still have the same issue.

zs&tas
Posts: 186
Joined: 18 Mar 2013, 17:07
x 3

Re: Oh no ! Xantia failed me this morning 🤪

Unread post by zs&tas »

Just seen someone swap out a coil even tho it tested good, same issue as me, I think I'm guna stop chasing stuff untill my new coil turns up . I mean that was my initial gut feeling and it was ordered 1/2 hour after I had the issue 😂😂

User avatar
ksanturion10
Posts: 102
Joined: 14 Oct 2018, 21:59
x 10

Re: Oh no ! Xantia failed me this morning 🤪

Unread post by ksanturion10 »

It's imperative, when you get in this particular situation ;), to look at the nice glowing exhaust with a big FIRE EXTINGUISHER in your hands - not kidding!

zs&tas
Posts: 186
Joined: 18 Mar 2013, 17:07
x 3

Re: Oh no ! Xantia failed me this morning 🤪

Unread post by zs&tas »

Haha you had experience Ksanturion10 ? I'm glad I did not try to drive too far !

User avatar
ksanturion10
Posts: 102
Joined: 14 Oct 2018, 21:59
x 10

Re: Oh no ! Xantia failed me this morning 🤪

Unread post by ksanturion10 »

Yeah, some bad experience actually :D . When I wrongly thought, that the glowing had stopped, decided to make a turn around the neighborhood, and just as I parked the car, went to see what is going on in the engine bay and... the fire protection started slowly burning... grabbed the fire extinguisher, it made only 3 puffs (brand new!), everything became white, but to my surprise the fire protection continued burning... ofcource panic came to play as I didn't had spare fire extinguisher... finally managed to put it down, but it was real struggle really.
Recently had some work done below the car, changed the hand brake cables and some other stuff, and actually saw that the most burned area was around the two petrol pipes going to the reservoir [-o< , maybe that was the reason why I didn't managed to put it down only with the fire extingiusher. Have to check the pipes more througly at this location as there could be the reason for the low mileage I'm getting with this engine.
But as a whole, it is not a joke ;)

zs&tas
Posts: 186
Joined: 18 Mar 2013, 17:07
x 3

Re: Oh no ! Xantia failed me this morning 🤪

Unread post by zs&tas »

Glad your all ok tho 👍 , that sound proofing stuff can really catch !