2017 Citroen C4 Grand Picasso screen wash pumps went silent and not working

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

sarchnary
Posts: 10
Joined: 11 Oct 2019, 10:11

2017 Citroen C4 Grand Picasso screen wash pumps went silent and not working

Unread post by sarchnary »

Hi all,

The washer jets just stopped suddenly. Weather was nice and warm so nothing was stuck, they just went silent.

Motor is fine and works fine, took it out for a test.

I can hear the relay clicks when I squeeze under the steering wheel control but nothing happens, this is the same case for rear wiper jet as well.

Is there a fuse or something? I can’t seem to find it on the glovebox passenger side.

Car is 2017 2.0HDi Grand Picasso Flair.

VF7**************[VIN obfuscated, can be read by forum staff]



it’s completely silent and doesn’t make any noise, there isn’t any leakage under the car. Might be electrical? Wouldn’t the motor turn and make noise even if pipes are loose or blocked?

Do these new models have a fuse for the washers as I can’t seem to find one in the manual or fuse box
Thanks for your help guys, the thing is mine is totally different 2017 flare version 2.0 blue hdi manual

F27 is 5A In dash and it’s working fine not sure what’s it for

Also engine by pay has crazy amount of fusses there.

The user manual diagram is kinda different to what’s on the actual car

Photos

https://s192.photobucket.com/user/sarch ... er%20motor

sarchnary
Posts: 10
Joined: 11 Oct 2019, 10:11

Re: 2017 Citroen C4 Grand Picasso screen wash pumps went silent and not working

Unread post by sarchnary »

Hello so, I’ve used a wire to power the motor directly from the battery and it’s working fine it washes front once and then rear once I change the terminal of the wire + to - and vice versa, so that makes me believe there is a power issue and the motor doesn’t get power.

I’ve read other posts here that people changed the wire and connector, only thing is it’s a short wire taped to the engine wiring loom so how do you change it? Do I need to open the taped wire and resolver it etc

Thanks

RichardW
Forum Treasurer
Posts: 9209
Joined: 07 Aug 2002, 17:12
x 360

Re: 2017 Citroen C4 Grand Picasso screen wash pumps went silent and not working

Unread post by RichardW »

It's likely the fuse for the washers in the under bonnet fusebox next to the battery.

sarchnary
Posts: 10
Joined: 11 Oct 2019, 10:11

Re: 2017 Citroen C4 Grand Picasso screen wash pumps went silent and not working

Unread post by sarchnary »

I have searched all fuses and would give it another go as I must have missed it if it’s in the under the bonnet fuse box thanks