C5 X7 estate o/s rear flasher not working & Aircon weird

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Peter.N.
Moderating Team
Posts: 9809
Joined: 02 Apr 2005, 16:11
x 289

C5 X7 estate o/s rear flasher not working & Aircon weird

Post by Peter.N. »

Went out in the red one this morning, first time in ages, noticed the r/h rear flasher wasn't working, checked the bulb and it was o/c, fitted a new one still no light, tested the new lamp OK. It did come on briefly once but not since, no voltage on the blue wire the feeds it, tail light OK, earth good. Is there a connector further down the line?

Another strange thing, the aircon has never worked on the silver one since I had it, been meaning to check the pressure but never got round to it. Yesterday I went out in that also for the first time in ages, suddenly realised that the vents were blowing very cold air on to me. Thought perhaps the pressure was low and the hot weather had increased it enough to switch it on so I thought I would top it up.

Surprise, surprise the gas pressure was almost off the gauge! well above the recommended pressure, I can only assume that it was considerably overcharged at some time. At least it shows that the system is pretty leak proof! Its still considerably over pressure, will it hurt yo use it like that? Don't think I am legally allowed to vent it into the air although I lost some as it kept blowing the connector off.

Thanks

Peter

Sorry can't delete the 'red'

User avatar
white exec
Moderating Team
Posts: 5888
Joined: 21 Dec 2015, 13:46
x 965

Re: C5 X7 estate o/s rear flasher not working & Aircon wierd

Post by white exec »

Red deleted: hopefully the faults can be too.
C.

Peter.N.
Moderating Team
Posts: 9809
Joined: 02 Apr 2005, 16:11
x 289

Re: C5 X7 estate o/s rear flasher not working & Aircon weird

Post by Peter.N. »

The indicator apparently healed up overnight. Started it this morning and it worked perfectly. :? :oops: :cry: :-D I left it turned off long enough to reset anything last night and it didn't work. The wipers are working OK now since I did a BSI reset - this car is weird. No problems with the other car - except the aircon and that's working now.

Peter

Online
User avatar
myglaren
Forum Admin Team
Posts: 17562
Joined: 02 Mar 2008, 14:30
x 849

Re: C5 X7 estate o/s rear flasher not working & Aircon weird

Post by myglaren »

Mine's not an X7 but does sometimes display a little Citroen Electrical Insanity© that is usually best ignored and corrects itself in time.

Filberton
Posts: 67
Joined: 05 Sep 2012, 20:39
x 5

Re: C5 X7 estate o/s rear flasher not working & Aircon weird

Post by Filberton »

Funny that, I have always had the same On mine but only on the rear lights.
(Stop light or indicator only, never side light) When one stops working I check and sure enough the bulb has blown. I replace it and the new one does not work. A meter test shows no voltage. I used to chase fuses etc. But like you, give it a couple of restarts and it all starts working again. I did wonder if it was something clever in the ecu.CANbus that shuts down power when it blows for safety until a couple of starts when O.K. I just treat it as normal now.

On the aircon, I believe there is a pressure safety valve in the compressor that vents back to the LP side when operating pressure is reached. Presumably if this sticks open then no pressure is created and no a/c but if it sticks closed then the system can over-pressurise? I guess the worst is the system could fail at the weakest spot which might be a fixable place or if In the heater matrix then no hope. If you are playing safe it might be best to either switch off on the dash to disengage the compressor or pull a fuse until you can find a knowledgable aircon guy? (There are pressure relief valves on fleabay so presumably they can be changed but as you say, legally it might be something for a certified aircon mechanic to do?

Mike

Peter.N.
Moderating Team
Posts: 9809
Joined: 02 Apr 2005, 16:11
x 289

Re: C5 X7 estate o/s rear flasher not working & Aircon weird

Post by Peter.N. »

I'm pleased to hear its not just mine Mike, all working OK now. I could fix the over aircon over pressure by releasing some, but I don't think that is legal, although what they think about all the gas that escapes due to normal leakage I don't know. I did find that my rechargeable gas can is empty, it wasn't when I last used it probably some years ago, I could probably vent some of the gas into that.

A mechanic at my local garage suspects that it was over pressurised but over the winter the pressure has dropped enough for it to work. Will have to think about what to do. Both cars are rarely used at the moment anyway.

Peter