Peugeot Partner 2.0 Hdi 2004 Engine noise

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

User avatar
Element
Posts: 46
Joined: 02 Mar 2014, 20:35
x 2

Peugeot Partner 2.0 Hdi 2004 Engine noise

Unread post by Element »

Hi, hope someone can figure this one out for me...

I have a 2004, 2.0Hdi Partner, last year around this time the crankshaft pulley begen to get noisy, squeaking if I remember. I changed it and changed the belt too. Fixed the noise. Then about a month later another different noise appeared, more of an agrivated hiss sound. As I'd just got another car I ignored the noise and left the Peugeot on the drive. It sat there until around October when I went to renew the mot. It failed on a couple of issues (brakes, Supension bushes etc) So I SORN'd it and left it alone, now and then giving time to repair the brakes etc. It sat un-moved until a couple of weeks ago when I decided to get it MOT's and sell it or do something with it. It started easily (always did) but this engine noise was still present and now to add to my woes, the oil lamp is lit and the dash has STOP flashing at me. Chatting to a few folks and hunting high & low for answers I thought I had the noise cornered and have just replaced the alt belt tensioner pulley.. Started up but the noise is still there (nothing wrong with the pulley :( ) .
So I'm now beginning to wonder whether there is a oil issue - I have checked the oil level & its good, plenty of oil. Kind of hoping that it isn't the 'oil pump' as 2 yrs back I had to replace the sump - undoing and refitting all of its 23 bolts... i don't fancy repeating that joy...
Other points - it runs fine, revs fine, drives fine, accelerates fine (no obvious turbo issue). Short of taking it to a garage and asking them to check it's oil pressure - is there any way of telling that the oil pump is defective.
The noise has not changed since last summer & back then the oil lamp and stop indicator did not light up - it was just noisy. It could be a duff oil sensor or connection and the oil thing could be a red herring.
There are no oil leaks at all.

I have recorded a wee video for the sound :



Your advice would be welcome! Thanks.

I have wondered whether it might be the water pump - but it too is not leaking. The sound does appear to be coming from the pulleys area or the top left side...

User avatar
Element
Posts: 46
Joined: 02 Mar 2014, 20:35
x 2

Re: Peugeot Partner 2.0 Hdi 2004 Engine noise

Unread post by Element »

I'm beginning to think it might be a turbo or other gas pipe cracked and this hiss sound might be air/gas escaping...

User avatar
Element
Posts: 46
Joined: 02 Mar 2014, 20:35
x 2

Re: Peugeot Partner 2.0 Hdi 2004 Engine noise

Unread post by Element »

Ok I have almost solved the noise... I took the drive belt off and ran the engine; no noise. This means it has to be among the remaining pulleys. Turned each one and of the three remaining, one feels a little gritty, still turns but not as smoothly as the other 2. Spent a good hour hunting for one online, found one and ordered, here on Monday. I think this case is solved.

pieter7472
Posts: 2
Joined: 24 May 2020, 19:16

Re: Peugeot Partner 2.0 Hdi 2004 Engine noise

Unread post by pieter7472 »

In my case it was crankshaft and overruning alternator pulleys.

User avatar
Element
Posts: 46
Joined: 02 Mar 2014, 20:35
x 2

Re: Peugeot Partner 2.0 Hdi 2004 Engine noise

Unread post by Element »

Changed the idler pulley this morning and no more noise.. fixed :)