Expert 2.0

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

MichalUK
Posts: 3
Joined: 07 May 2020, 20:50

Expert 2.0

Unread post by MichalUK »

Expert 2011 2.0 HDI 120hp

Bought at 178.000 miles

Things been changed at 180,000 miles

Water pump
Klutch
Flywheel
Timing belt
New oil
New radiator
New cooling liquid
New gearbox oil
Head gasket + heavy cleaning (oil from the cover)
New A/C radiator
Thermostat

Plus mechaninc takes money for checking every single bolt and others things...(he is a good friend i been there the whole time he did that)


Car was ok even sound of engine was like new, when starting the engine it was like a rocket one turn a booom... i was very happy first week it felt like new van )when turbo kicks in it smoked little bit)...on motorway i got (repair needed) on dashboard and lost power...ive stoped and check under bonnet, everything ok, oil water temperature .... then turbo start working again....its going like this for 2 weeks...it stops working and then start to work again ....i notice a oil leak under the car from (turbo section)


Any expert? or can anyone recommend what his happening with the engine

Hell Razor5543
NOT Alistair or Simon
Posts: 10332
Joined: 01 Apr 2012, 09:47
x 941

Re: Expert 2.0

Unread post by Hell Razor5543 »

Hi, and :welc: to the forum.

It may not be the turbo. If a serious fault occurs (that turns on the Engine Management Light (EML)) it is possible that the ECUs put the engine into 'Limp Mode' to prevent potential damage to the engine, but with enough power to (hopefully) get you home.

You will need to get the van onto a Lexia system. A generic code reader will not help you here. There are Forum members who could help out here (although, with the current lockdown, they won't be available at this time) as they have Lexia equipment. Here is the link to the members who have a Lexia;

https://www.frenchcarforum.co.uk/forum/ ... hp?t=56452

MichalUK
Posts: 3
Joined: 07 May 2020, 20:50

Re: Expert 2.0

Unread post by MichalUK »

Hell Razor5543 wrote:
07 May 2020, 21:13
Hi, and :welc: to the forum.

It may not be the turbo. If a serious fault occurs (that turns on the Engine Management Light (EML)) it is possible that the ECUs put the engine into 'Limp Mode' to prevent potential damage to the engine, but with enough power to (hopefully) get you home.

You will need to get the van onto a Lexia system. A generic code reader will not help you here. There are Forum members who could help out here (although, with the current lockdown, they won't be available at this time) as they have Lexia equipment. Here is the link to the members who have a Lexia;

https://www.frenchcarforum.co.uk/forum/ ... hp?t=56452
Thats what i thouht because when working it is flying on the road...but whats with the oil leaking my mechanic said it turbo sealing or what ever im not not car guy sorry