C5 X7 Hdi. No apparent turbo boost

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Peter.N.
Moderating Team
Posts: 9882
Joined: 02 Apr 2005, 16:11
x 329

C5 X7 Hdi. No apparent turbo boost

Unread post by Peter.N. »

Fitted a new starter to my red one a few days ago and did actually have to go out in it a day or two later, drove fine until I came to a hill. put my foot down and nothing much happened. I don't know if its something I have done or a coincidence, checked that I had plugged the MAF in, which I had, disturbed very little else. I have had it off before with no ill effects, any suggestions. Still don't have a working Lexia. :oops:

Another strange thing, I never did find out what was causing the intermittent wipers but every time I disconnect the battery when they are not working they spring into life again. :?

Peter

lexi
Donor 2019
Posts: 2728
Joined: 17 Apr 2008, 17:51
x 110

Re: C5 X7 Hdi. No apparent turbo boost

Unread post by lexi »

I can't help with your problem Peter. You are some man though in still messing with cars given your "maturity"?
Stay safe.

wheeler
Posts: 4090
Joined: 21 Sep 2002, 19:07
x 128

Re: C5 X7 Hdi. No apparent turbo boost

Unread post by wheeler »

Did you disturb any air pipes to get to the starter? if so I would check none have popped back off. Can you hear any 'wooshing' noises when you rev it up? do you feel the air hoses puffing up when revved?

Peter.N.
Moderating Team
Posts: 9882
Joined: 02 Apr 2005, 16:11
x 329

Re: C5 X7 Hdi. No apparent turbo boost

Unread post by Peter.N. »

Helps to keep me 'fit' Lexi.

All I disturbed as far as I know were the air intake pipes and filter box and the intercooler to engine pipe but I connected them again securely the only plug I disconnected was the MAF lead.

No urgency as it still drives and I have the other one anyway, I would just like to fix it.

Peter

User avatar
xantia_v6
Forum Admin Team
Posts: 7270
Joined: 09 Nov 2005, 23:03
x 387

Re: C5 X7 Hdi. No apparent turbo boost

Unread post by xantia_v6 »

Check that no vacuum hoses have been pinched or fallen off.

User avatar
white exec
Moderating Team
Posts: 5969
Joined: 21 Dec 2015, 13:46
x 981

Re: C5 X7 Hdi. No apparent turbo boost

Unread post by white exec »

With no turbo available, your mpg figures, Peter, are set to become stratospheric! :monkey:

Peter.N.
Moderating Team
Posts: 9882
Joined: 02 Apr 2005, 16:11
x 329

Re: C5 X7 Hdi. No apparent turbo boost

Unread post by Peter.N. »

That thought had crossed my mind Chris :-D Unfortunately for the immediate future I'm not going to be able to find out. Should have been going to Scotland next month. :(

Peter

User avatar
white exec
Moderating Team
Posts: 5969
Joined: 21 Dec 2015, 13:46
x 981

Re: C5 X7 Hdi. No apparent turbo boost

Unread post by white exec »

Maybe that's where we should hold our eventual "get together" (with Mick) then . . .?

Peter.N.
Moderating Team
Posts: 9882
Joined: 02 Apr 2005, 16:11
x 329

Re: C5 X7 Hdi. No apparent turbo boost

Unread post by Peter.N. »

Nice quiet roads - like everywhere else at the moment!

Peter

Gibbo2286
Donor 2020
Posts: 4472
Joined: 08 Jun 2011, 18:04
x 710

Re: C5 X7 Hdi. No apparent turbo boost

Unread post by Gibbo2286 »

My experience of no turbo has been that the thin rubber vacuum pipes between the vac pump, the electrovalves and the turbo have split or are porous through age, splits very difficult to see without really careful examination.

That's barring of course the turbo itself being blown which would be apparent with the smoking exhaust.

Peter.N.
Moderating Team
Posts: 9882
Joined: 02 Apr 2005, 16:11
x 329

Re: C5 X7 Hdi. No apparent turbo boost

Unread post by Peter.N. »

No smoke just a loss of power, I will check the vacuum pipes in due course. Thanks.

Peter