Bad idle/hard to start warm - Citroën ZX 1.6i -92

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

oliverw
Posts: 8
Joined: 21 Mar 2020, 19:05

Bad idle/hard to start warm - Citroën ZX 1.6i -92

Post by oliverw »

Hello there!

I'm totally unfamiliar with Citroën, but I've now owned this car for a month approxmatiely. I recently changed the timing belt, (or not me, a mechanic I know...). Car is running good, but now and then this engine light turns on (the one with a k-sign), but only when the car gets hot (working temp), also only when driving highway, so from 80 km/h.

It doesn't affect the driving anything, but it is annoying of course.

Starts perfectly cold, but can be harder when warm. Need to pump the gas a little.

So far I've changed spark plugs, ignition cables, oil and filter, fuel filter, air filter and today I changed the o2 sensor in hope that would be the main thing for my troubles.

But no...

Still have this CE light on, and smells also quite bad from the exhaust. Smells alot petrol, even though lambda is brand new (OEM Bosch).

And I have the 1.6i engine (65kw)

BDY (XU5M); BFZ (XU5JP); Petrol 88hp 65kw 1.6 i 03/1991-06/1997

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21212
Joined: 15 Sep 2015, 19:38
x 2115

Re: Bad idle/hard to start warm - Citroën ZX 1.6i -92

Post by GiveMeABreak »

Do you have the VIN so we know for sure what it is you have - these are 2 separate engines.

oliverw
Posts: 8
Joined: 21 Mar 2020, 19:05

Re: Bad idle/hard to start warm - Citroën ZX 1.6i -92

Post by oliverw »

GiveMeABreak wrote:
21 Mar 2020, 20:14
Do you have the VIN so we know for sure what it is you have - these are 2 separate engines.
Hi! Yes, N2B40000B45514

User avatar
myglaren
Forum Admin Team
Posts: 18208
Joined: 02 Mar 2008, 14:30
x 1037

Re: Bad idle/hard to start warm - Citroën ZX 1.6i -92

Post by myglaren »

That seems to be missing some characters. Where did you get that from?

oliverw
Posts: 8
Joined: 21 Mar 2020, 19:05

Re: Bad idle/hard to start warm - Citroën ZX 1.6i -92

Post by oliverw »

Haha, that's the chassienumber I guess? But it's the 88hp model 65kw

oliverw
Posts: 8
Joined: 21 Mar 2020, 19:05

Re: Bad idle/hard to start warm - Citroën ZX 1.6i -92

Post by oliverw »

The engine looks like this :

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21212
Joined: 15 Sep 2015, 19:38
x 2115

Re: Bad idle/hard to start warm - Citroën ZX 1.6i -92

Post by GiveMeABreak »

The VIN is usually on the bottom left corner of the outside of the windscreen in a cutout. It will begin with V and an F and a 7.

oliverw
Posts: 8
Joined: 21 Mar 2020, 19:05

Re: Bad idle/hard to start warm - Citroën ZX 1.6i -92

Post by oliverw »

GiveMeABreak wrote:
22 Mar 2020, 18:47
The VIN is usually on the bottom left corner of the outside of the windscreen in a cutout. It will begin with V and an F and a 7.
Okay, I will look it up. Posting it tomorrow, working at the moment :)

oliverw
Posts: 8
Joined: 21 Mar 2020, 19:05

Re: Bad idle/hard to start warm - Citroën ZX 1.6i -92

Post by oliverw »

When I look on car info they also refer to that number when looking VIN 😋

User avatar
white exec
Moderating Team
Posts: 6241
Joined: 21 Dec 2015, 13:46
x 1051

Re: Bad idle/hard to start warm - Citroën ZX 1.6i -92

Post by white exec »

The VF..... number is also likely to appear on the car's documentation.

User avatar
ksanturion10
Posts: 145
Joined: 14 Oct 2018, 21:59
x 16

Re: Bad idle/hard to start warm - Citroën ZX 1.6i -92

Post by ksanturion10 »

oliverw wrote:
21 Mar 2020, 19:21
But no...

Still have this CE light on, and smells also quite bad from the exhaust. Smells alot petrol, even though lambda is brand new (OEM Bosch).

And I have the 1.6i engine (65kw)
Hi, had similar issues ;)
Have you managed to track your fuel consumtion till now? What do you pour in?

BR
Martin

User avatar
citroenguy
Posts: 46
Joined: 21 Sep 2017, 18:05
x 11

Re: Bad idle/hard to start warm - Citroën ZX 1.6i -92

Post by citroenguy »

In the Swedish documentation the VF7**************[VIN obfuscated, can be read by forum staff] is usually missing on old cars (eg BX,ZX) , but in C-service you can always put in the 8 last digits an it will come up.
For this car i got VF7**************[VIN obfuscated, can be read by forum staff]
it is TU5M

I guess it has magneti marelli injection, so you should be able to get blink codes out of it.

oliverw
Posts: 8
Joined: 21 Mar 2020, 19:05

Re: Bad idle/hard to start warm - Citroën ZX 1.6i -92

Post by oliverw »

ksanturion10 wrote:
23 Mar 2020, 20:37
oliverw wrote:
21 Mar 2020, 19:21
But no...

Still have this CE light on, and smells also quite bad from the exhaust. Smells alot petrol, even though lambda is brand new (OEM Bosch).

And I have the 1.6i engine (65kw)
Hi, had similar issues ;)
Have you managed to track your fuel consumtion till now? What do you pour in?

BR
Martin
Hi Martin :)

Yeah, I'm gonna fuel him up today or tomorrow :) There's also something wrong with the fuel gauge, so it's not trustworthy at all.

But I've purchased a better used speedometer on eBay, and I really hope fuel gauge will work properly after change...

I was also in contact with a Peugeot/Citroen mechanic the other day. He was quite sure of the coolant temp sensor that is sitting on the backside of the head. Saw that the sensor and contact had a lot of old oil all over the place. Gonna clean up that and replace with a new one. Let's see...

User avatar
ksanturion10
Posts: 145
Joined: 14 Oct 2018, 21:59
x 16

Re: Bad idle/hard to start warm - Citroën ZX 1.6i -92

Post by ksanturion10 »

Beeee, hi Oliver :D,
well, if your really had changed all that stuff, that means you made a considerable funding, to where it should, and you might be deserving a little hint :wink:
First, don't know nothing about this model of Citroen, and I can only speak with relations to mine. So, what makes me an impression is the resemblance with the "petrol" smell, which is a bit awfull really.
One of the things I did, in my 3 month struggle with a non properly working engine, which kind of eased the smell for some time, was the removal of all the old petrol inside the tank, and pouring brand new fuel from a 10 L can.
Good petrol have definitive smell, which you should remember from your pre 90's stops at petrol stations, if some :).
Get a good electrical contact cleaner and go through any one out there, and also, keep your original parts if you are not buying an original spares.
I see you are resorting to an additional qualified help, so probably the best would be to keep it that way... 8-[

BR
Martin

oliverw
Posts: 8
Joined: 21 Mar 2020, 19:05

Re: Bad idle/hard to start warm - Citroën ZX 1.6i -92

Post by oliverw »

Well...

A little update guy's...

The car is in need of a proper timing belt setting.

The mechanic I let work on the ZX didn't get the proper setting, because it runs bad on idle when warm. The idle first stalls like 3-500 (maybe) RPM but goes up right after and run pretty ok...

Also a little weaker at the moment. Takes like 1 liter or a little more. Were out on a trip and used the trip meter. Had like 400 km and filled about the same amount in litres (40l).

Otherwise good haha 😁

I'm gonna let it be now and wait for the mechanic to contact me. And he's gonna fix it, trustworthy guy who also made the wheel alignment setting on each axle, front and rear.

//Oliver