What's a good working VVT anticipation or retard value ?

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

David_CH
Posts: 46
Joined: 21 Jan 2020, 13:29
x 3

What's a good working VVT anticipation or retard value ?

Post by David_CH »

Hello guys, as the subject, i have this question :

after succesfully replacing the timing belt ( i admit, with a lot of troubles ) the engine was working fine for one day, then the miserable P0011 and P0012 error appeared on my diagnosis tool and the scary "low oil pressure" warning on the car too.
First of all, there isn't any low oil pressure issue, this was what the ecu has come up after the previous codes.

I'm thinking that some connection problem with the solenoid or the position sensor is the issue, since we had to remove the valve cap to remove the VVT pulley (this is another story).

While doing some live diagnosis, i've noticed some strange values on the timing angle so i would like to ask if anyone know what is the good range of a working EW10A engine (-15 to +15 degrees, or more ?)

Anyway, even with this errors, the motors run fine, and the message on the dashboard it disappear itself during driving.
Also there is not any "klicking" or other scary noises from the engine. Only sometimes, the idles goes lower (this make me thinking that the solenoid remain stuck somewhere).

Thanks !

David_CH
Posts: 46
Joined: 21 Jan 2020, 13:29
x 3

Re: What's a good working VVT anticipation or retard value ?

Post by David_CH »

Well, over a month later... "low oil pressure warning" still here.

Sometime happen every 2 minutes, sometimes the car run fine for hours.
Very very strange since it started happening after the camshaft cover was removed and reinstalled.
Already tried replacing the pressure sensor, and changed oil + filter with good 5w40 oil. At first the problem disappeared for 2 days, then back on.

No engine sound "tickling" during the drive, only if i stop the car and stay at idle for 3-4 minutes then she start making a clicking noise, like if the vvt doesn't change anticipation.

I'm in doubt if spending again money to let the garage remove the sump and clean the picking tube, or simply sell the car as not working.. which is a shame because it's still a nice car :(