Still can’t get a good seal on oil feed pipe !

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Benscab123
Posts: 158
Joined: 09 Jul 2019, 20:33
x 3

Still can’t get a good seal on oil feed pipe !

Post by Benscab123 »

After fitting new turbo and oil feed pipe, I still can’t get a good seal on the feed pipe, even after tightening, retightening (several times), removing copper washers and heating them up to soften and refitting, using 2 different sets of brand new washers !!!
It’s still leaking oil . Is there anywhere else in that area that could leak oil ? It settles on top of the turbo actuator. Driving me nuts 🥜.
Leak wasn’t there before new turbo by the way and feed pipe was tightened to manufacturers spec to begin with.
admiral51
Donor 2021
Posts: 2376
Joined: 24 May 2007, 10:11
x 300

Re: Still can’t get a good seal on oil feed pipe !

Post by admiral51 »

The pipe seal is i believe a right PITA to do correctly.
Assuming the pipe was not replaced during turbo replacement then have a look here as it shows correct alignment and a possible source for a new replacement part.
I cannot see any other area where the leak could be coming from
Benscab123
Posts: 158
Joined: 09 Jul 2019, 20:33
x 3

Re: Still can’t get a good seal on oil feed pipe !

Post by Benscab123 »

The pipe WAS replaced with a brand new one along with new copper washers.
admiral51
Donor 2021
Posts: 2376
Joined: 24 May 2007, 10:11
x 300

Re: Still can’t get a good seal on oil feed pipe !

Post by admiral51 »

Benscab123 wrote:
16 Feb 2020, 16:47
The pipe WAS replaced with a brand new one along with new copper washers.
Then in that case take it back to them and say sort it, you paid hard cash, its not right