2002 206 2.0hdi, no EML not starting any suggestions, thank you

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

Tulwar
Posts: 3
Joined: 15 Nov 2019, 22:25

2002 206 2.0hdi, no EML not starting any suggestions, thank you

Post by Tulwar »

Hi,
would appreciate any help with this problem.

Just done a top end overhaul on engine and fitted new clutch, engine refitted but quickly started engine to check all OK (inlet ducting fitted and the cooling system not fitted) . Engine ran fine (just let it tick over for 30 seconds). 8-)

But after installing the inlet ducting, air box, rad, pipework etc. The problem arose. :roll:

Lift pump not working, so checked inertia switch, fuses, checked earthing cables....all OK. Checked double relay and, as part of the casing was broken, carefully removed/broke open the rest of the casing, 4 diodes are inside. Checked them and found 2 diodes were faulty.

Replaced relay with new but still no power to lift pump.

Now I've noticed that the EML does not come on at all. So assuming the ECU is not powering up, would be perhaps a wiring problem/break ? a fuse I missed ?

Please....Does anyone know the pin outs on the Bosch EDC15 variant 2 ECU, I need the pins for constant power, ignition switch power and earth so I can trace wiring

Central locking etc all working fine, if ignition key left in ignition the warning sound works, so not immobiliser ?

Grateful for any help, Thank you

Hell Razor5543
NOT Alistair or Simon
Posts: 10234
Joined: 01 Apr 2012, 09:47
x 912

Re: 2002 206 2.0hdi, no EML not starting any suggestions, thank you

Post by Hell Razor5543 »

Hello, and :welc: to the forum. To help the Moderators get the right equipment details for your car could you please post the VIN here? It will, for security reasons, be obscured so only forum staff can read it.

Tulwar
Posts: 3
Joined: 15 Nov 2019, 22:25

Re: 2002 206 2.0hdi, no EML not starting any suggestions, thank you

Post by Tulwar »

Thanks for the reply and welcome Hell Razor, will post VIN , directly on the forum ??

Hell Razor5543
NOT Alistair or Simon
Posts: 10234
Joined: 01 Apr 2012, 09:47
x 912

Re: 2002 206 2.0hdi, no EML not starting any suggestions, thank you

Post by Hell Razor5543 »

Yes, it is safe to do so, for the reason I mentioned.

Tulwar
Posts: 3
Joined: 15 Nov 2019, 22:25

Re: 2002 206 2.0hdi, no EML not starting any suggestions, thank you

Post by Tulwar »

Problem is now sorted.

Finding I had power to the dual relay, made me remove the air filter etc. to re-check connections around the gearbox and also check the round multi-connector fitted to lower passenger wing.

I found some SPIDERS WEB across several contacts of the multiplug, cleaned and refitted.....and lo and behold the EML illuminated

Car now starts fine, not certain what happened but assume that there was enough contact with the connector to start the car, maybe vibration or moving the wiring around when refitting air box ..broke the 'good' contact.

pulled the loom about in case of a bad wire....but seems fine.

thanks ...