Update. My Gti Turbo

An area for all matters concerning the Citroen CX.

Moderator: RichardW

Bilkob
Posts: 97
Joined: 23 Feb 2017, 20:16
x 6

Update. My Gti Turbo

Post by Bilkob » 26 Jun 2019, 08:00

Some on here may remember my ups and downs with the afforementioned beast!
The hot cutting out issue was definitely fuel pump
I've also fallen foul of the turbo inlet pipe creeping off and causing extremely rough running, bad starting, e tc,
Also, I found some horrendous bodged wiring by the 2 fuel pump relays and have replaced the relays As well
When the car runs well it is lovely now, strong, fast smooth. BUT, it STILL has an intermittent fault, it will sometimes start to hunt, and then the revs will rise slightly and then it will be very hard go pull away smoothly, needs a lot of revs, and runs very rich. I'm pretty sure that when this happens, the turbo boost vague moves from it's middle stop and moves slightly to the right....
Oh, and I've also replaced the fuel pressure regulator
Thinking caps on again!

User avatar
CGATCX25GTITURBO
Posts: 281
Joined: 21 Nov 2010, 11:58
x 3

Re: Update. My Gti Turbo

Post by CGATCX25GTITURBO » 07 Jul 2019, 09:07

Throw the plugs away. Start with fresh plugs check the ignition circuit coils and leads if you haven't. Check the gap on the flywheel sensors.
Has - had it had a clutch recently?
I've seen the slug on the flywheel damaged and cause issues
Does the boost gauge move to a positive? Could be map sensor related, vac hose off etc.
Does the tps work okay?
Are the three wires connected properly, might need to look at the Haynes BOL a d check the pin out back to the ECU.