RNEG2 not working

This unit is the eMyWay system, also referred to as RT6, RNEG2, or WIPNAV+ for the Peugeot platform and made by Magneti Marelli.
Main Features: The eMyWay colour satellite navigation has high resolution mapping, Bluetooth Telephone & Audio Streaming supported profiles, USB support for Media files & CD

Moderator: RichardW

Sambeattie94
Posts: 2
Joined: 20 Jan 2019, 14:49

RNEG2 not working

Post by Sambeattie94 »

Hi guys,

I have a 2013 308 with the RNEG2 system. A few weeks ago it stopped displaying anything on the flip up screen on the dash and the head unit itself doesn’t seem to power up properly. I have taken the unit out and checked all the wiring/ fuses and everything seems fine. I have also checked the power and the radio is getting 12v and grounded okay etc.

The only thing it will do is make a noise as if it’s trying to eject a CD every 30 seconds or so (no cd inside)

Anyone any ideas as a second hand unit of eBay is around £500

Any help appreciated thanks in advance

Hell Razor5543
Donor 2021
Posts: 11664
Joined: 01 Apr 2012, 09:47
x 1394

Re: RNEG2 not working

Post by Hell Razor5543 »

Hi, and :welc: to the Forum. Before doing anything further I would suggest you get a DagBox session done on the car, as there could be any number of reasons for a fault. There are Forum members who have Lexia clones and are willing to help out. Here is the link;

viewtopic.php?f=19&t=56452

Sambeattie94
Posts: 2
Joined: 20 Jan 2019, 14:49

Re: RNEG2 not working

Post by Sambeattie94 »

Thanks for the reply,

I have an Autel MaxiSys and have tried getting using it but it won’t communicate with the radio (will communicate with all other systems) so I don’t think a Dagbox session will come to much

User avatar
GiveMeABreak
Forum Admin Team
Posts: 24375
Joined: 15 Sep 2015, 19:38
x 2666

Re: RNEG2 not working

Post by GiveMeABreak »

Was there anything you can think of that would of coincided with this happening such as any other equipment additions / accessories you may have installed? Have you made any changes to the BSI, added any other aftermarket kit?

Your Autel probably won't cut it to be honest - Diagbox will be able to deal with the head units too - which aftermarket scanners mostly won't.

It is possible that the EPROM could be fried, or the unit has overheated (they do suffer from this as they are so compact). Have you tried rebooting or resetting the unit, or doing a BSI reset?

drumvlado
Posts: 21
Joined: 30 Jan 2014, 16:15

Re: RNEG2 not working

Post by drumvlado »

Hi.
I would guess that you either need to change the SD card and install/configure it from the start - that would be the easy option. Or, you have a major problem with it that will require to change it.
Either way, above else, get a CD with it's firmware and stick it in and see what happens. The sound it makes is from the CD, I guess the unit is trying to say "I need a CD now".
Vladimir

oskitoski88
New User
Posts: 1
Joined: 16 Dec 2020, 11:03

Re: RNEG2 not working

Post by oskitoski88 »

Hi! I’ve had the exact same issue with my rneg2. The sound every 30 sec is driving me crazy. Going to try and install a new stereo to see what happens. How did it go for you?

Oskar
Norway