Engine issue with 2006 Relay 2.2hdi

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Relay -mike
Posts: 2
Joined: 21 Nov 2018, 18:32

Engine issue with 2006 Relay 2.2hdi

Post by Relay -mike »

Hello, my first post and I am seeking help !

From the outset I will state I am not the most mechanically minded, please be gentle and apologies if I don’t understand.

I have a Citroen Relay LWB campervan. It is a 2006 model and has 55000 on the clock. Regular service and I like to think well looked after. I use the same garage in Glasgow that I have used for years, good reputation and helpful.

The issue with the engine started about 6 months ago. I was driving along when the engine just cut out. The red engine management light came on and when I put the clutch in the dashboard lit up like a disco. I managed to get the van off the road and then panicked. The engine would turn, the battery was fine and everything seemed fine except it would not start. I was about to phone the AA when the engine fired up. No warning lights and it all seemed fine. I managed to get to my destination without any further issues. I then drove about 250 miles home with no issues.
I took the van to be checked out, nothing found. Everything seemed fine.
The problem however kept on happening. Sometimes I can go over 500 miles with the van not missing a beat. Then it will happen two or three times within a hundred miles.
It happens in rain, sun hot engine cold engine acceleration or coasting. I cannot explain any unique cause.
I have had it in the garage and there is no fault. The fuel pumps are all fine. The electrics appear fine also. An auto electrician checked it out. No fault code and no problems.
The bottom line is that the garage has said that they cannot fix a fault they can’t find. It has never happened when in at the garage.
I have had suggestions of fuel starvation that then clears / resets hence the no fault. The garage cannot rule that out but think unlikely.
I am hoping that some of you may have a previous experience of something similar with a possible solution??
The wierdest part of this is my friend also has a Citroen Relay camper, bought after the great reviews I gave mine, his is a 2004 but has also recently developed the same problem. He has had egr valves and sensors replaced but still the problem continue
Hell Razor5543
Donor 2021
Posts: 11933
Joined: 01 Apr 2012, 09:47
x 1485

Re: Engine issue with 2006 Relay 2.2hdi

Post by Hell Razor5543 »

Hi, and :welc: to the Forum. While I am not going to be able to help you, it won't take long before somebody pops in who can offer advise.
Simple76
Posts: 113
Joined: 13 Sep 2018, 18:19
x 9

Re: Engine issue with 2006 Relay 2.2hdi

Post by Simple76 »

Very strange fault. Does seem like a fuel problem have you changed fuel filter?. Does it start ok
User avatar
NewcastleFalcon
Posts: 16953
Joined: 25 Feb 2009, 11:40
x 1834

Re: Engine issue with 2006 Relay 2.2hdi

Post by NewcastleFalcon »

Well this thread may give a bit of information, but as with so many of its ilk, no solution by the final post.


http://forums.outandaboutlive.co.uk/for ... es-/44784/


It may be the case that the 2.2 hdi fitted to your Relay, is one of Ford’s creations the 2,198cc 'puma'’ as fitted to the transit, jaguar x type etc. Not difficult to find threads outlining problems, very few ending in solutions.

Regards Neil
Relay -mike
Posts: 2
Joined: 21 Nov 2018, 18:32

Re: Engine issue with 2006 Relay 2.2hdi

Post by Relay -mike »

Thanks for the suggestions and the link.
The fuel filter has been changed, although wasn’t needed but changed regardless. The van starts straight away normally, only a delay after the fault, takes a minute to clear or cool down whatever is causing the issue, and then starts straight away again. No excess smoke when travelling or on restart.
It is a real pain, as never sure when it will happen if at all. The garage has done lots of minor changes, cleaned connections, earths, filters etc. Checked the pumps. Nothing founds that could cause the issue.
charlie garage
Posts: 1
Joined: 20 Jan 2021, 12:58

Re: Engine issue with 2006 Relay 2.2hdi

Post by charlie garage »

hi I had the same problem started about 18 month ago, I have a 04 relay 2.2hdi, converted to a camper, serviced every 6 months, well looked after, it has me baffled, same problems with cutting out, sometimes the radiator fans kick in with red engine light lit up, now it has gone one step further, it wont start unless i use easy start, then runs perfect, when engine is switched off it wont start again unless i use easy start .i have had it at Citroen main dealers for diagnostic check and has no faults, I have changed glow plugs and relay, all injectors, high pressure pump and low pressure pump, cam and crank sensors, fuel pressure sensor, battery and starter motor ,fuel filter, everything has been replaced with new items, no change, have checked all wires and plugs cleaned and replaced every earth, still wont start without easystart, engine doesnt smoke, I have over 42 years in the motor trade 12 of those with citroen , hate to admit it but i am stuck,