2009 308sw 2.0hdi cutting out problem

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

To many Pugs
Posts: 3
Joined: 09 Feb 2018, 20:56

2009 308sw 2.0hdi cutting out problem

Post by To many Pugs » 10 Feb 2018, 14:01

Wife bought this last April all was fine then it started cutting out always started again within a minute of stopping this carried on sometimes driving a few miles then hundreds of miles fast forward to just before xmas it got worse until it failed to start completely had t tow it home the next morning it started so I let it run still running an hour later turned it off 2 hours later no go. Put Diagbox on it global scan no faults then decided to remove rear seats to access fuel pump no sound of pump running for a few seconds as most Peugeots do, then decided to unplug the 3 plugs on the main under bonnet fuse box all contacts clean no corrosion put them back on car started then I unplugged the 3 plugs and stopped the engine when I got to the inner one put back on car started put Diagbox back on global test loads of faults because unplugging whilst engine running cleared faults rescanned no faults then with car running remove plug from fuel pump and was surprised it did not stop ( Does the high pressure pump not need prime pump when running?) So far I have done a few local trips no problems any ideas of any other reason it stops, cant find a wiring diagram anywhere. Lately the car stopped about a mile from home would not start so towed it home, battery went flat so to remove it was a struggle as it sits under the bulkhead had to hold the plate with all the +ve wires on it out of the way, anyway on refitting the battery the car then started again so now is it corrosion on these wires the car is too unreliable to drive any distance until I find the exact fault.Regards Iain

User avatar
demag
Donor 2016
Posts: 1436
Joined: 18 Oct 2004, 05:03
x 77

Re: 2009 308sw 2.0hdi cutting out problem

Post by demag » 10 Feb 2018, 15:19

Did the tank pump run when you turn on the ignition? They usually run for a few seconds to prime the system.

To many Pugs
Posts: 3
Joined: 09 Feb 2018, 20:56

Re: 2009 308sw 2.0hdi cutting out problem

Post by To many Pugs » 10 Feb 2018, 20:03

As you have asked that this is what I thought it would do having had 5 406s & a 307 they all did it but a guy on the RAC forum seems to think they dont I had the back seat out and on the pump there is a different plug to earlier Peugeots when I had it running I removed this plug and it carried running to my surprice, I had a 406 with a dodgy pump I us to lift up the seat and thump the floor and it would go again for weeks or months without a hitch. When this 308 dies it is just like the ignition had been switched off this is why I am looking for an electrical fault,earlier the electric power steering failed and that was one of the motor feed wires had corroded away.

wheeler
Posts: 3832
Joined: 21 Sep 2002, 19:07
x 84

Re: 2009 308sw 2.0hdi cutting out problem

Post by wheeler » 11 Feb 2018, 17:13

It may not have an in tank pump depending on what injection system is fitted though it may still be wired for one.
If there is a hand primer pump in the engine bay then it wont have an in tank pump. The fact that it doesn’t cut the engine when you unplug the tank unit suggests to me there wont be an in tank pump on this car.
If you unplug the tank unit & there are only 2 pins on the unit (not the plug) then its just a fuel sender. If there are 4 pins its a combined pump & fuel sender unit.

To many Pugs
Posts: 3
Joined: 09 Feb 2018, 20:56

Re: 2009 308sw 2.0hdi cutting out problem

Post by To many Pugs » 11 Feb 2018, 17:21

Yes it has the primer pump and only 2 wires on the tank