MyCitroen website - broken?

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Richard_C
Donor 2016
Posts: 490
Joined: 15 Oct 2011, 17:31
x 59

MyCitroen website - broken?

Post by Richard_C »

Some of you might use the MyCitroen website - you can register your car and see maintenance schedules, recalls, documentation and the suchlike. If you have a recent (Mid 2015 on) car with Mapcare - free satnav updates - its the only route to get those updates.

The site has been down since late March, reporting error 142, some bits look as through they might work but the error makes it impossible to get map updates. It's been commented on in another less active forum. I have used Chrome, Safari and IE11, and done all the usual clear cache stuff so I think its them not me.

Could I ask any forum members who have registered with the MyCitroen website to try it and report what they see - if it works then the browser and OS info would be good.

If its not working for you, you could go onto the ordinary citroen uk website and fill in a customer care contact form. I did that a week ago, got a reply written by a human being - will report to web team they said - but the site is still down. Maybe a few more prods are needed to get their attention.

User avatar
myglaren
Forum Admin Team
Posts: 17556
Joined: 02 Mar 2008, 14:30
x 846

Re: MyCitroen website - broken?

Post by myglaren »

Just registered and got the following:
Screenshot at 2017-04-17 16-31-31.png
ETA: Firefox 52.02on Linux Mint 18.1 Serena.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 19511
Joined: 15 Sep 2015, 19:38
x 1875

Re: MyCitroen website - broken?

Post by GiveMeABreak »

Richard_C wrote:The site has been down since late March, reporting error 142, some bits look as through they might work but the error makes it impossible to get map updates. It's been commented on in another less active forum. I have used Chrome, Safari and IE11, and done all the usual clear cache stuff so I think its them not me.


Firefox 53.0 (32-bit)
Safari IOS 10.3.1
Opera 39.0.2256.48
Microsoft Edge 38.14393.0.0

Windows 10 Pro 64 Bit
IOS 10.3.1
Ok on all browsers / OS

Richard_C
Donor 2016
Posts: 490
Joined: 15 Oct 2011, 17:31
x 59

Re: MyCitroen website - broken?

Post by Richard_C »

Thanks for this. Most odd - maybe its broken for some accounts rather than the whole site. I have prodded customer care again, I am still seeing the error as are some people on another forum. Perhaps its just accounts with map care attached. Will post here if I find anything more.

RichardW
Forum Treasurer
Posts: 9205
Joined: 07 Aug 2002, 17:12
x 358

Re: MyCitroen website - broken?

Post by RichardW »

Check you are not using a hidden IP address - I can't access service.citroen at work as the IP address is hidden.