hello all

A forum for new members to introduce themselves to the rabble already onboard. Not compulsory!
Tell us a little about yourself, lie if you have to but keep it to just an introduction, not a car discussion.

Moderator: RichardW

daveellis
Posts: 6
Joined: 14 May 2016, 19:56

hello all

Post by daveellis » 14 May 2016, 20:27

Hi to all I'm Dave and have a major tale of woe.
My sons c3 HDi 16v wouldn't start the other day so he got relayed home from college and I got to work with my Lexia. Only fault was BSI communication fault to steering column switch so we got another module and plugged in still no joy. Old fella says check 20amp micro fuse.
This had blown changed it today and all was well erased fault.
Started her up again now have all warning lights on no fuel reading side lights stay on and ac mixer motor clicking with the keys out of the ignition any help please

Online
User avatar
xantia_v6
Forum Admin Team
Posts: 5546
Joined: 09 Nov 2005, 23:03

Re: hello all

Post by xantia_v6 » 14 May 2016, 20:35

It sounds like a BSI reset would be a good moved. If you search this site you should find instructions.

And welcome to the site.

Online
User avatar
myglaren
Forum Admin Team
Posts: 14503
Joined: 02 Mar 2008, 14:30

Re: hello all

Post by myglaren » 14 May 2016, 21:30


daveellis
Posts: 6
Joined: 14 May 2016, 19:56

Re: hello all

Post by daveellis » 14 May 2016, 21:32

Thank you for the reply will try it in the morni g and let you know how it goes

User avatar
Stickyfinger
Donor 2016
Posts: 9251
Joined: 28 Mar 2013, 22:05

Re: hello all

Post by Stickyfinger » 14 May 2016, 21:39

Hellloooo


As a tip, when you do it, give the battery a good charge for a few hours (go mow the lawn/have breakfast) and reconnect with a good charge in the battery.

daveellis
Posts: 6
Joined: 14 May 2016, 19:56

Re: hello all

Post by daveellis » 14 May 2016, 22:22

Will do

daveellis
Posts: 6
Joined: 14 May 2016, 19:56

Re: hello all

Post by daveellis » 15 May 2016, 18:00

Update
Done bsi reset and no change all warning lights still displayed.
Lexia says
Bsi cannot communicate with instruments panel
Bsi cannot communicate with air con ecu
Have checked all fuses and all are ok. Thinking now that the bsi is goosed

Online
User avatar
myglaren
Forum Admin Team
Posts: 14503
Joined: 02 Mar 2008, 14:30

Re: hello all

Post by myglaren » 15 May 2016, 18:03

If it is it may be fixable.
When James (HellRazer) spots this he will supply the name and address of a guy who repairs them for a very agreeable price compared to a new one.

Hell Razor5543
NOT Alistair or Simon
Posts: 8180
Joined: 01 Apr 2012, 09:47

Re: hello all

Post by Hell Razor5543 » 15 May 2016, 19:29

Erm, I have never had to have a BSi repaired. Did you mean a different James by any chance, Steve?

Online
User avatar
myglaren
Forum Admin Team
Posts: 14503
Joined: 02 Mar 2008, 14:30

Re: hello all

Post by myglaren » 15 May 2016, 21:19

No, convinced it was you who had made the recommendation before James.
Wrong again :(
I blame the Alzheimers* :(

*Which the spellcheck would have as Altimeters :roll:

Anyway, I believe that BBA Reman do them but there is another highly recommended repairer, somewhere in the Leeds/Manchester area.

daveellis
Posts: 6
Joined: 14 May 2016, 19:56

Re: hello all

Post by daveellis » 16 May 2016, 14:01

Gonna try bsi reset again tonight when i get off work car now starts but lots of lights on dash when doing tbe reset should i fully disconnect battery or just remove negative from it

User avatar
Stickyfinger
Donor 2016
Posts: 9251
Joined: 28 Mar 2013, 22:05

Re: hello all

Post by Stickyfinger » 16 May 2016, 16:28

Just the neg clamp needs removing

daveellis
Posts: 6
Joined: 14 May 2016, 19:56

Re: hello all

Post by daveellis » 16 May 2016, 20:06

Dod reset and nada check fuses and all ok so i unugged black plug on bsi now there is no ignition lights no dash display nothing at all