2.0 hdi 2004 lost power won't start.

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Ltyson22776
New User
Posts: 1
Joined: 20 Feb 2016, 20:14

2.0 hdi 2004 lost power won't start.

Post by Ltyson22776 »

Hi guys i own a 2004 fiat scudo van withe the Peugeot 2.0 hdi engine in. I had taken my dad on a road trip to get a new vehicle last Saturday and it never missed a beat, until I got around 10 miles from home where I pulled off a roundabout and the power just went instantly no judder or misfire just shut right off but still running smoothly. I pulled into the next lay-by and the van was still running but when you tried to accelerate it would begin to rev up to about 2000 rpm then drop back down on its own then up then downt etc even when you keep your foot to the floor. I turned it off to try reset but it would not restart it tries to fire but just not quite. So I got a tow home off my dad and bumped it off along the way again same symptoms. I've been working on it all week and so far I have scanned for codes none present but fuel temp sensor circuit which I think was always there. Checked turbo intake side checked rockers and timing checked woodruff key on cam changed high pressure fuel reg and rail pressure sensor (used parts) swapped injectors (used) changed fuel filter checked primary pressure which seems ok. It's driving me mad it will start on easy start then stay running and sounds totally fine as soon as it hits that 1500-2000 rpm as its about to boost it drops right off. Any help greatly appreciated. Thankyou