C5 Screen washers

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

kayjas
Posts: 51
Joined: 15 Feb 2016, 19:06

C5 Screen washers

Post by kayjas »

C5 Estate - 2.0 HDI 2003

For some reason my screen washers are taking a while before water comes out.
The jets don't appear blocked (pin in hole) and its the same when weather is warm.
The rear seems fine.
Any ideas ?
BenC5HDi
Not Mike
Posts: 588
Joined: 30 Nov 2015, 21:21
x 33

Re: C5 Screen washers

Post by BenC5HDi »

I believe the non-return valve in the pipeline to the washers has failed, allowing water to drain back to the tank, so that when you use them again, it has to pump all the way back up from the tank. My car does exactly the same on the front washers, but the rear is instant (and they run from the same bottle and pump, under the bonnet)

I ordered a couple of generic non-return valves off eBay for £3, and will fit them when they arrive on Friday and post the result.
kayjas
Posts: 51
Joined: 15 Feb 2016, 19:06

Re: C5 Screen washers

Post by kayjas »

BenC5HDi wrote:I believe the non-return valve in the pipeline to the washers has failed, allowing water to drain back to the tank, so that when you use them again, it has to pump all the way back up from the tank. My car does exactly the same on the front washers, but the rear is instant (and they run from the same bottle and pump, under the bonnet)

I ordered a couple of generic non-return valves off eBay for £3, and will fit them when they arrive on Friday and post the result.
Wow that's it ! Sounds like it could be the problem. Do you know where the non return valve is situated in the pipeline ?
BenC5HDi
Not Mike
Posts: 588
Joined: 30 Nov 2015, 21:21
x 33

Re: C5 Screen washers

Post by BenC5HDi »

I've no idea, I imagine it's a simple in-line one in the feed from the tank to the washers. I'm not going to bother looking for mine unless it's obvious, I'll just cut the pipe and push the replacement in. They're just a push-fit into the hose.
kayjas
Posts: 51
Joined: 15 Feb 2016, 19:06

Re: C5 Screen washers

Post by kayjas »

Brilliant - Thanks BenC5HDi
BenC5HDi
Not Mike
Posts: 588
Joined: 30 Nov 2015, 21:21
x 33

Re: C5 Screen washers

Post by BenC5HDi »

The non-return valve solved the problem and took me all of 30 seconds to fit. I simply cut the washer pipe where it joins the bonnet and put the valve in the pipe there. Result = instant washers.

Pic to follow in a bit when I get to a PC.
BenC5HDi
Not Mike
Posts: 588
Joined: 30 Nov 2015, 21:21
x 33

Re: C5 Screen washers

Post by BenC5HDi »

As promised...

first, I bought a pair of these off eBay

http://www.ebay.co.uk/itm/401067288729? ... EBIDX%3AIT

They look like this - they have an arrow on to mark the direction of flow..

Image

I simply cut straight through the washer pipe feed where it joins the bonnet, pushed one into the pipe, and job done. Washers working properly.

Image

I hope that helps you!
kayjas
Posts: 51
Joined: 15 Feb 2016, 19:06

Re: C5 Screen washers

Post by kayjas »

I went out and bought the same part £2 - fitted an hey presto its working just like new.
I can't thank you enough ! I love it when you fix things :-)