RT3ev Navidrive problem 2007 C5 old model

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

C5exclusive
Posts: 6
Joined: 08 Feb 2016, 17:52

RT3ev Navidrive problem 2007 C5 old model

Post by C5exclusive »

Hello everyone,
I bought a C5 2.2 hdi twin turbo exclusive. It is the last of the facelift older model. It is fully loaded! It has the CD stack under the drivers seat. It says on the sat nav screen ''please insert upgrade cd'' and on the bottom left hand side 2.13
I thought I would book it in with Citroen as all that works is the heater blower, and, as I simply bought it for the gadgets, I wanted them all working.
J.C Campbell Citroen in Rostrevor Co. Down couldn't fix it as it had no CD disk inside and they told me they would have to order one.
Charles Hurst told me if I get the disk they can load it and program it through the diagnostic port ( 2 hours labour and £160 for the disc )
Anyway, before I start throwing £70+vat an hour at my car, can anyone enlighten me on how to get my radio and sat nav up and running?

I have purchased CD SOFTWARE 8.31 from Citroen - I put it into the RT3ev slot and nothing happened with the car running 2 hours as I am aware the car might go into limp.
This is very frustrating as it has all these bells and whistles and I am driving with no radio or car settings.
I am willing to post the unit away if need be to get the big lady running like she should.

All comments appreciated, Justin RT3eV - N3 - Q2 96650253YW
jgra1
Posts: 4571
Joined: 27 Nov 2005, 20:07
x 22

Re: RT3ev Navidrive problem 2007 C5 old model

Post by jgra1 »

hi Justin, and welcome - I cant help with the cd maps upgrade thing, others will have useful knowledge of that.

but wait on with the dealers!

if you have an XP laptop, or buy one (I may even have one lying around) then you can get the proper diagnostics, for about £80 ish..
then you will have all the access the dealers have, a must for these cars.. and for the time you own it..

John

ps there may be others in your area that have the kit, the Lexia interface, that could help.
C5exclusive
Posts: 6
Joined: 08 Feb 2016, 17:52

Re: RT3ev Navidrive problem 2007 C5 old model

Post by C5exclusive »

Hi John,
Thanks for your help. That might be all way over my head. I can use a fault code reader direct into the 16 pin OBD port, but I wouldn't have a clue going any further ( at least I don't think so, unless I had tutoring :)

I have a TomTom in the car at the moment and headphones from my mobile phone. A lot of use all this software is in a car if you can't use it 'and also interfering with the climate and trip' the cheeky buggers :)
Hopefully someone in N. Ireland can help me with this, of a postal request. Citroen seem to want me to just throw money at it!

Justin
User avatar
GiveMeABreak
Forum Admin Team
Posts: 26039
Joined: 15 Sep 2015, 19:38
x 2985

Re: RT3ev Navidrive problem 2007 C5 old model

Post by GiveMeABreak »

Justin do you have the RT3 Navidrive system or the RT4/5 system that was on some models from 2007? Can you PM your VIN through so we can be sure on the spec. Having a look now to check software versions, but need to be sure on the system. If it's the V8.? of the software then that smacks of an RT4/5, so need to be sure.

Meanwhile, if you hold the MENU button on the head unit down for about 5 seconds, it should display the unit and software versions if it's an RT3
User avatar
GiveMeABreak
Forum Admin Team
Posts: 26039
Joined: 15 Sep 2015, 19:38
x 2985

Re: RT3ev Navidrive problem 2007 C5 old model

Post by GiveMeABreak »

OK - might have a solution. Although the unit says RT3 on the label, it may well be an RT4 unit from what I can tell. Assuming you have tried the update and you aren't getting anywhere here is a suggestion.

Undo the screws and slide out the headunit, disconnect the wiring blocks. Check the fuse while you have this out. On the underside there should be 2 white buttons next to each other. If you can see these, remember where they are located and plug all the wires back in but keep the unit out.
Start the car (in case economy mode kicks in) and make sure the CD is not in the unit. Then, whilst holding in the 2 white buttons, at the same time insert the CD. Keep the 2 buttons held down for a minute, then let them go. This should force the unit to boot from the CD. If so, great, don't interrupt it. If not try it again. This usually happens as a result of a failed previous update (possible previous owner). Let us know how you get on. If you are successful and the system boots properly, you may find there are quite a few options that will need to be reset using Diagbox / Lexia to reprogram the system to the car. You cannot programme the system whilst it is in the current state. If you do get it booting properly, symptoms could be some controls not working, sound, emergency services not working etc. This will be normal until it is programmed in with all the correct parameters. But before we go there, try and get it to this state first. :-D
C5exclusive
Posts: 6
Joined: 08 Feb 2016, 17:52

Re: RT3ev Navidrive problem 2007 C5 old model

Post by C5exclusive »

Hi Marc,
Thanks for your answers. The unit in the car says RT3eV-N3-Q2
The date on it is 27/02/29 meaning someone before has used a fresher 2nd hand one.
I took it out of the dash and unclipped the large plug exposing the fuse. The fuse is ok. I cannot see any white buttons or anything like that on the unit.
After about 10mins I reconnected with the car running. It kept ejecting the CD SOFTWARE 8.31 after 2 seconds. it done this 3 times and then kept it in and nothing happened. The CD wasn't even making a spinning noise as you would hear.

The only way I can take out the CD is by rebooting using the DARK button and teasing it out with another CD and pressing the eject button.

As I drive the car it is continually rebooting itself every 10mins or so. It must be looking something.

Justin
User avatar
GiveMeABreak
Forum Admin Team
Posts: 26039
Joined: 15 Sep 2015, 19:38
x 2985

Re: RT3ev Navidrive problem 2007 C5 old model

Post by GiveMeABreak »

The white buttons are on the underside of the unit - did you not see those? If they aren't there then, this may not be the right unit - as I asked before, can you send me a Private Message with your C5's car VIN in order to confirm correct unit, otherwise you might not be getting the right advice.
Is it one of these units?
Image
I can't help further without the right info Justin. :-D
C5exclusive
Posts: 6
Joined: 08 Feb 2016, 17:52

Re: RT3ev Navidrive problem 2007 C5 old model

Post by C5exclusive »

Hi Marc,
Yes that is the same as mine. VIN VF7**************[VIN obfuscated, can be read by forum staff]

I can find nothing on the underside to indicate any buttons.

Justin
User avatar
GiveMeABreak
Forum Admin Team
Posts: 26039
Joined: 15 Sep 2015, 19:38
x 2985

Re: RT3ev Navidrive problem 2007 C5 old model

Post by GiveMeABreak »

Justin, now I've looked up your system I can see this was an RT4 system as fitted to late Facelift C5s and the Citroen C6. It is referred to in the docs as RT4 + COLOUR NAV.
I don't think I'm going to be much more help except refer you to a few links. The image below is where the 2 white buttons are located and they should be there (but they are not easy to see).
Image
This chap on the Citroen Car Club had the same issue, but he managed to reset his using the technique I described and got it back to a working unit. He just then needed to re-programme a few features. Here is the link:
http://www.citroen-owners-club.co.uk/ci ... -recovery/
Here's a link to a repairer for these units too in case this fails:
http://www.mapleaudio.co.uk/
C5exclusive
Posts: 6
Joined: 08 Feb 2016, 17:52

Re: RT3ev Navidrive problem 2007 C5 old model

Post by C5exclusive »

Marc...great results!!
Without going any further I had a second look for them 'micro buttons' - did exactly what you told me - it took about 6 times, and each time the 8.31 disk was harder to eject having to tease it out with another CD after holding the DARK button in for 10seconds.

FINALLY - BOOM !!! It totally rebooted from August 2006 :) I drove the car an hour before it restarted glancing at it's % process! It was a joy to watch it doing it all by itself...my girlfriend and I had a great couple of hours setting it all up listening to the last owners 'Juke Box' :)

Very delighted...car handles better, directional lamps work, parking sensors work and all European Maps are up to date with voice command

All over the head of them secluded 'micro buttons' ........ Citroen seriously haven't a clue...and don't care either! I'm still waiting on Head Office to get back to me over a week after emailing them. I will sleep well tonight :)

Thank you soo much,

Justin :)
jgra1
Posts: 4571
Joined: 27 Nov 2005, 20:07
x 22

Re: RT3ev Navidrive problem 2007 C5 old model

Post by jgra1 »

=D> :twisted:
Good news Justin!

I had to change my engine to uncover previous owners jukebox !!

Almost put the old engine back in :twisted:
C5exclusive
Posts: 6
Joined: 08 Feb 2016, 17:52

Re: RT3ev Navidrive problem 2007 C5 old model

Post by C5exclusive »

Haa...I'd put up with listening to anything but road noise...his collection takes me back to the Talbot Sunbeam years :)

All the bells and whistles are working...now I just need to keep my eyes on the road...oh, that's right...I have a vibrating seat now if I don't show due care and attention...happy days !!
User avatar
GiveMeABreak
Forum Admin Team
Posts: 26039
Joined: 15 Sep 2015, 19:38
x 2985

Re: RT3ev Navidrive problem 2007 C5 old model

Post by GiveMeABreak »

You're welcome Justin, I'm really pleased for you as it is a good peice of kit. I bought a pay as you go sim and shoved that in the unit for phone on my 05 Navidrive, but I'm guessing you've got Bluetooth on this unit? My unit read the text messages with a voice that was a cross between Regan in The Excorcist and Lilly Savage after. 3 bottles of Whisky! Anyway best of luck with the car, glad you persevered and got the result you wanted 8-)