206 1.9 d

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

xdever
Posts: 4
Joined: 21 Aug 2015, 02:23

206 1.9 d

Post by xdever »

Hello everyone. I have a problem with my peugeot 206. Its a 1.9 d WD8 69bhp. Now i heard a lot of ppl say they have knocking sound on cold motor but for me its the other way around. Driving on the motorway just before i got off it the engine got realy loud... anyway i got to my destination, went to work... after 4 hours. Went started the motor on cold like nothing happend. Any advice what that can be? No smoke, coolant temp. doesnt rise, not loosing power or distrupt the motor or cut off... just knocking loud
User avatar
CitroJim
A very naughty boy
Posts: 49932
Joined: 30 Apr 2005, 23:33
x 6287

Re: 206 1.9 d

Post by CitroJim »

Welcome :-D

This is a diesel knock and not a big-end knock I assume!

Sadly, I'm not 100% familiar with the DW8 but assume it has the Lucas Injection Pump. On this the pump injection timing is set electronically and I believe it takes one of it's timing reference signals from a needle lift sensor embedded in one of the injectors.

These sensors are known to fail and can give rise to the problem you are experiencing... It is a very common issue on the earlier but related XUD9 engine with Bosch Injection...
Jim

Runner, cyclist, time triallist, duathlete, Citroen AX fan and the CCC Citroenian 'From A to Z' Columnist...
xdever
Posts: 4
Joined: 21 Aug 2015, 02:23

Re: 206 1.9 d

Post by xdever »

Thanks for the fast reply :) I think it is a Lucas pump and i will look at the injector sensor and ill let you know. I drove the car this morning for like 50 miles and it was ok. One more thing... When the car is hot if i stop and leave it for a bit turn the key just before starting the car leave it like this ( listen to music) after turn back the key and start on the display in the mid said ECO mode. Can this have something to do with it?
User avatar
CitroJim
A very naughty boy
Posts: 49932
Joined: 30 Apr 2005, 23:33
x 6287

Re: 206 1.9 d

Post by CitroJim »

No, that's just the BSI (Body Computer) going into a sleep mode... Nothing to worry about at all and is normal under the circumstances you describe...
Jim

Runner, cyclist, time triallist, duathlete, Citroen AX fan and the CCC Citroenian 'From A to Z' Columnist...
User avatar
chinkostu
Posts: 1180
Joined: 24 Sep 2014, 09:41
x 30

Re: 206 1.9 d

Post by chinkostu »

either crank sensor or the needle lift sensor are having a fit. mine used to do this, a thorough clean of the plugs to everything seemed to help.

mine also hates the rain!
Stu

Cars
1995 Xantia 1.9TD SX in (faded) Red
2003 Fiesta 1.4 Zetec in GREEEEEEEN
2001 206 1.9 LX
2001 Saxo VTR
1999 Saxo 1.1 East coast
1999 Punto :oops:
1996 306 1.8 XN Auto :?
1996 Fiesta 1.3 #-o
xdever
Posts: 4
Joined: 21 Aug 2015, 02:23

Re: 206 1.9 d

Post by xdever »

Sorry for the slow reply... yes it was a lucas pump and it was the injector. However i didnt change it because it stoped doing it. It was the diesel tank that was the problem. Because i ran it the night before on low fuel it sucked what ever was on the bottom of it and fooled the injector... BTW i will never get fuel from Tesco again... you have no idea what was on the bottom of the tank.

Thanks a lot to all of you specially Jim for the fast reply. And i hope the info i gave will be helpfull too...
User avatar
CitroJim
A very naughty boy
Posts: 49932
Joined: 30 Apr 2005, 23:33
x 6287

Re: 206 1.9 d

Post by CitroJim »

Excellent :-D It is very useful to know that a bit of bad fuel can upset the injector sensor...

Indeed, the bottoms of diesel tanks, even the ones on your own cars, can be a right chamber of horrors after a few years.. It all sinks to the bottom!
Jim

Runner, cyclist, time triallist, duathlete, Citroen AX fan and the CCC Citroenian 'From A to Z' Columnist...
User avatar
chinkostu
Posts: 1180
Joined: 24 Sep 2014, 09:41
x 30

Re: 206 1.9 d

Post by chinkostu »

Might be worth running some injector cleaner through the filter housing, clear any crud out!

I've luckily not had any issues from running them low
Stu

Cars
1995 Xantia 1.9TD SX in (faded) Red
2003 Fiesta 1.4 Zetec in GREEEEEEEN
2001 206 1.9 LX
2001 Saxo VTR
1999 Saxo 1.1 East coast
1999 Punto :oops:
1996 306 1.8 XN Auto :?
1996 Fiesta 1.3 #-o
xdever
Posts: 4
Joined: 21 Aug 2015, 02:23

Re: 206 1.9 d

Post by xdever »

I will get a redex fuel sistem cleaner! I wasnt expecting fuel to be a problem for a mono injection but it seems it is !!!