407 1.6HDi No Power, Black Smoke

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

Nelix
Posts: 14
Joined: 14 Aug 2015, 10:46
x 1

407 1.6HDi No Power, Black Smoke

Post by Nelix »

Hi

I have the above vehicle and am having a few issues, here is the story:

I bought the car as a non runner, after towing the vehicle home I put a new battery on it and it started first time!!!! However when driving it had no power under 2500-3000 revs. After a few days of driving it lost all power and would not rev over 2000-2500 rpm, it did not even have enough power to pull away on a fairly flat road, I also got the "anti pollution fault" message.

I plugged the diag machine in (Peugeot Planet) and it informed me that the DPF was blocked. I also suspected the Turbo was at fault, so as money is tight at the moment I replaced the turbo cartridge/CHRA, while I had the car in bits I removed the DPF and gave it a good clean with a pressure washer and Mr Muscle oven cleaner. After putting the car back together it still has no power, still won't rev over 2000 (occasionally revs to 3000-3300 when warm) and lots of black smoke. I managed to get it out of the yard and it won't go over 10mph.

As there is black smoke I am assuming it's air flow related, live data informs me that the air-flow figure is about 20% down on what it should be so I removed all of the Air Flow system including the inlet manifold and thoroly cleaned it all and replaced the rubber seals where it go's into the cam cover.......... started the engine and still the same.

The EGR vavle had been blanked off so I removed the blanking plate but this did nothing to solve the issue, if anything the air flow is registering upto 50% expected.

Does anyone have ant clues as to what I could try next?

Kind Regards

Nelix
User avatar
Stickyfinger
(Donor 2016)
Posts: 10545
Joined: 28 Mar 2013, 22:05
x 1346

Re: 407 1.6HDi No Power, Black Smoke

Post by Stickyfinger »

MAF sensor I would think, but that is total guess work, it must be throwing some other faults ?

Age
Engine
last 8 of the Vin would help
Alasdair
Activa, the Moose Dogger
Nelix
Posts: 14
Joined: 14 Aug 2015, 10:46
x 1

Re: 407 1.6HDi No Power, Black Smoke

Post by Nelix »

The engine is the 1.6 HDi (everyone run and hide :) )

I tried unplugging the MAF and it made no difference

It's on a 55 plate

Last 8 is as follows: 21347952

No fault codes at all which puzzles me!

Kind regards

Nelix
User avatar
Gibbo_Wirral
Posts: 183
Joined: 17 Jul 2013, 14:34

Re: 407 1.6HDi No Power, Black Smoke

Post by Gibbo_Wirral »

I'd get a second opinion from another Planet owner.
Peugeot Planet Diagnostics: Wirral, Merseyside, Lancashire, Cheshire, North Wales
Nelix
Posts: 14
Joined: 14 Aug 2015, 10:46
x 1

Re: 407 1.6HDi No Power, Black Smoke

Post by Nelix »

Fitted new MAF and worse than it was, revs at idle constantly fluctuates between about 550 upto 900, up and down, up and down.

When the MAF is unplugged it sits nicely at 800

Strangely, when it was first started after fitting it ran great...... For about 30 seconds, reved much better too