Has anyone encountered top mount bearings this bad?

This is the place for posts that don't fit into any other category.

Moderator: RichardW

davie206
Posts: 55
Joined: 29 May 2014, 20:26

Has anyone encountered top mount bearings this bad?

Post by davie206 » 15 Nov 2014, 23:57

I was replacing a broken spring when I came accross the bearing which I think could have caused the spring to twist and snap.
It is that badly corroded that It has part of it still seized round the metal rest plate and only a grinding disc or replacement plates will will help in this instance.[img][IMG]http://tapatalk.imageshack.com/v2/14/11 ... f02084.jpg[/img][/IMG]

davie206
Posts: 55
Joined: 29 May 2014, 20:26

Re: Has anyone encountered top mount bearings this bad?

Post by davie206 » 16 Nov 2014, 00:01

Image
Image

User avatar
CitroJim
A very naughty boy
Posts: 41564
Joined: 30 Apr 2005, 23:33
x 1033

Re: Has anyone encountered top mount bearings this bad?

Post by CitroJim » 16 Nov 2014, 05:42

Gosh :shock: What vehicle was that on Davie?

davie206
Posts: 55
Joined: 29 May 2014, 20:26

Re: Has anyone encountered top mount bearings this bad?

Post by davie206 » 16 Nov 2014, 10:26

A 206. Looks like it could have still been on the original bearings, need to try find small grinding discs today or else its replacement plates

citronut
Posts: 10938
Joined: 29 Apr 2005, 00:46
x 3

Re: Has anyone encountered top mount bearings this bad?

Post by citronut » 16 Nov 2014, 10:28

trouble with the bearings at this point dont seem to have any defence against nature and the elements,
looks like your balls are out of shape as well :yikes: :eye: :eye: :twisted: :-D :lol: :rofl2: :rofl2:
hope you dont mine me mentioning it :-D :wink:

citronut
Posts: 10938
Joined: 29 Apr 2005, 00:46
x 3

Re: Has anyone encountered top mount bearings this bad?

Post by citronut » 16 Nov 2014, 10:31

just did a goooooly search

http://www.ebay.co.uk/itm/PEUGEOT-206-3 ... 0416037161" onclick="window.open(this.href);return false;

and this was one of the first results that came up

davie206
Posts: 55
Joined: 29 May 2014, 20:26

Re: Has anyone encountered top mount bearings this bad?

Post by davie206 » 19 Nov 2014, 20:43

Haha cheers bud got 2 new top mount bearings from euro car parts for £15 and done both sides. New spring and top junts and what a difference in road noise :)

citronut
Posts: 10938
Joined: 29 Apr 2005, 00:46
x 3

Re: Has anyone encountered top mount bearings this bad?

Post by citronut » 19 Nov 2014, 23:16

davie206 wrote:Haha cheers bud got 2 new top mount bearings from euro car parts
i'd be surprised if they last long from that bunch :evil: :roll: #-o

RichardW
Forum Treasurer
Posts: 8854
Joined: 07 Aug 2002, 17:12
x 309

Re: Has anyone encountered top mount bearings this bad?

Post by RichardW » 19 Nov 2014, 23:31

The ones on our C4 were nearly in that state:

Image

I changed them pretty soon after they started being noisy, they were only 7 years / 75k miles old. New OE SKF ones are only about £13.50 from Citroen - I got some a bit cheaper than that from e-bay. They're best described as 'built down to a price' though. I did at least grease them before they went in, so should outlast my ownership of the car!

davie206
Posts: 55
Joined: 29 May 2014, 20:26

Re: Has anyone encountered top mount bearings this bad?

Post by davie206 » 20 Nov 2014, 08:26

Looks like you got to them before a spring snapped lol
Last edited by davie206 on 20 Nov 2014, 19:46, edited 1 time in total.

citronut
Posts: 10938
Joined: 29 Apr 2005, 00:46
x 3

Re: Has anyone encountered top mount bearings this bad?

Post by citronut » 20 Nov 2014, 09:52

davie206 wrote: I got a pack of 2 skf top mounts from euro for £15
say no more 8-[ :roll: :wink:

addo
Sara Watson's Stalker
Posts: 7098
Joined: 19 Aug 2008, 12:38
x 2

Re: Has anyone encountered top mount bearings this bad?

Post by addo » 20 Nov 2014, 11:02

citronut wrote:say no more 8-[ :roll: :wink:
#soontobebutthurt

User avatar
Dommo
Posts: 1169
Joined: 11 Apr 2009, 09:43
x 8

Re: Has anyone encountered top mount bearings this bad?

Post by Dommo » 09 Feb 2015, 18:51

I had this same issue on my 306, it also caused a spring to fail while doing a car park manouvre. The top mount bearings dont appear to have much (if any?) grease in nor do they have much if any protection from the elements!

User avatar
Zelandeth
Donor 2016
Posts: 3248
Joined: 17 Nov 2014, 00:36
x 267

Re: Has anyone encountered top mount bearings this bad?

Post by Zelandeth » 12 Feb 2015, 23:06

Looks very much like the one that was changed on my 306 just before I got it!