Condensor Connections

Post your Cit/Peu/Ren air conditioning queries or advice.

Moderator: RichardW

hamster99
Posts: 262
Joined: 21 Jun 2009, 15:20
x 1

Condensor Connections

Post by hamster99 »

Have removed damaged condensor on wife's C3 and am about to order replacement.

The double O ring seals on the two pipes seem to be OK but should I use some sort of lubricant or sealant when I fit the new condensor.

If so, then what should I use?

Rob

steelcityuk
Posts: 1053
Joined: 03 Jul 2006, 21:51
x 1

Re: Condensor Connections

Post by steelcityuk »

The same oil as specified for the A/C system. Usually PAG.

Steve.

Eddie Nuff
New User
Posts: 476
Joined: 15 Nov 2012, 21:31
x 36

Post by Eddie Nuff »

Yeah I know the thread's three years old but I thought the title might lead to an answer for my question.

Swmbo's C4GP has a split air con pipe, from the condenser down to the compressor. The compressor end has come off easy but the other end will not budge. I've tried to manipulate it with a screwdriver with no joy and I'm loathe to attack it with anymore force as the condenser is a good one.

Any ideas on how to prise the pipe free without destroying the condenser end?

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21546
Joined: 15 Sep 2015, 19:38
x 2159

Re: Condensor Connections

Post by GiveMeABreak »

What's your VIN? (PM it over and I'll have a squiz for you)

Here's the main diagram - I've sent the procedures abd related documents to you via email as they are too big to put here.
C4GP AC System
C4GP AC System
(24) cylinder.
(25) low pressure valve.
(26) high pressure valve.
(27) pressostat.
(28) Pressure reducer for principal circuit .
(29) Pressure reducer for additional circuit .
(30) Filtring and drying cartridge.

There is a pressure relief valve shown, but not sure if that will be preventing the pipe from coming off. You'll need new o rings though - but hopefully this may contain some info to help!

RichardW
Forum Treasurer
Posts: 9294
Joined: 07 Aug 2002, 17:12
x 378

Re: Condensor Connections

Post by RichardW »

I had this trouble when I changed the condenser on my 307. In principal the stud can be used as a puller as it has an E-spline fitting on the end (E4 IIRC) and a washer under the lobe on the pipe. However, when I tried this with the connection stuck it just ripped the splines off the end of the stud. I eventually got it out by wiggling it a lot until it freed the lobe off the stud, then I was able to wiggle it out. So, if I was doing it again I would remove the nut, then scrape / wiggle the connector till it started to move, then use the stud to pull it out. I think it is dissimilar metal corrosion between the steel stud and aluminium lobe that is the problem. Coke might dissolve this - but then you'd probably need to get the condenser out to turn it on its back to flood it - which means getting the other connection out as well - as that tube is one piece all the way round the back of the engine, so you definitely don't want to wreck that! I got a new condenser for the 307 for about £60, so it's not a disaster if you have to scrap it....

PS I recall I had the radiator out, which improves the access no end - I was struggling with the bottom connection; I think you are trying to get the top one out?

Eddie Nuff
New User
Posts: 476
Joined: 15 Nov 2012, 21:31
x 36

Post by Eddie Nuff »

Marc, thanks for the email, the diagrams are very handy.

Richard, yes it is the top one and it does feel as though it's sealed together.

The condenser itself looks in really good condition, as though it's been a fairly recent replacement. It's certainly in better knick than the spare I have.

Won't be until tomorrow aft when I can have a bash at this now.

Eddie Nuff
New User
Posts: 476
Joined: 15 Nov 2012, 21:31
x 36

Post by Eddie Nuff »

Went out to the car this morning, opened the bonnet, pulled on the pipe and the damned thing came straight off! :twisted: :lol:

All back together now. Thanks folks.

Hell Razor5543
NOT Alistair or Simon
Posts: 10831
Joined: 01 Apr 2012, 09:47
x 1091

Re: Condensor Connections

Post by Hell Razor5543 »

It got frightened!