Xsara Picasso Hdi90 probs.

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

rmunns
Posts: 551
Joined: 09 Jul 2009, 22:09
x 3

Xsara Picasso Hdi90 probs.

Post by rmunns » 15 Jun 2012, 08:09

I've had this 2004 car for 3 months or so - a low miles (39k) one owner car. But somehow it doesn't seem right - several pointers to high miles for example. But after replies to a posting I did a few weeks ago, I convinced myself that, while low miles, it has been a high-usage car. Clutch pedal rubber worn, seats a bit scruffy, cruise control not working, all four areas under door handles extensively scratched. Droney diff? is that possible? Drones from 20mph to 80mph, whether in gear or not, clutch in or out. Fuel consumption is good - have now done 3 trips France - UK at 2000km per trip - getting 52 mpg (topped up tank figures, computer shows a bit less than this). Having said that I expected 60mpg - I am a very careful to squeeze as good a fuel figure as I possibly can. My Xantia 72000miles Hdi90 does 50mpg (over last 34000 miles).
On last trip to UK the right hand area of the speed display has faded badly. I'm running in kilometres, for example at 120km/h the '2' and the '0' are faded. This definitely happened during last trip. Also the switches to increase/decrease this brightness don't work anymore.
Sorry this has been a rambly sort of posting, I just wrote as I thought. Comments, please.

rmunns
Posts: 551
Joined: 09 Jul 2009, 22:09
x 3

Re: Xsara Picasso Hdi90 probs.

Post by rmunns » 15 Jun 2012, 08:13

Oh, nearly forgot.

I cannot undo the screw that lowers the spare wheel. Rusted very badly. PlusGas has not freed it; I did try a blowtorch, but was afraid I would damage the spare wheel, so I didn't give it much heat. I would like help on this, please, I am obviously vulnearable (I do have a tin of squirt, but that's no good if I get bad tyres damage). I have also used hammer and metal rod, to no effect.

citronut
Posts: 10938
Joined: 29 Apr 2005, 00:46
x 3

Re: Xsara Picasso Hdi90 probs.

Post by citronut » 15 Jun 2012, 08:23

maybe some bulbs have blown in your display,

the wheel rack hook/bolt will need heat, so you need to place a sheet of metal or asbestos/heat proof material between the heat and the tyre,
also mind you dont get to much heat on the body work ofr this will encourage the tin worm to attack,

once you have freed it off dismantle it completely and give it a good doss of copper slip,

the only other option is chop it off and get a replacement, new or second hand

regards malcolm

wheeler
Posts: 3811
Joined: 21 Sep 2002, 19:07
x 81

Re: Xsara Picasso Hdi90 probs.

Post by wheeler » 15 Jun 2012, 18:50

It will defo just be a couple of bulbs out in the display, really easy to change, all you need it some sort of plastic spatula to prise of the surround then the display is just held in by 2 T-20 screws, the bulbs are just a quarter twist to remove

wheeler
Posts: 3811
Joined: 21 Sep 2002, 19:07
x 81

Re: Xsara Picasso Hdi90 probs.

Post by wheeler » 15 Jun 2012, 18:52

Also a new spare wheel hook & bolt aint that expensive even from the dealers, might be less hassle just to chop it !

User avatar
Scruffy ferret
Posts: 4
Joined: 06 Dec 2013, 00:35

Re: Xsara Picasso Hdi90 probs.

Post by Scruffy ferret » 16 Nov 2014, 20:13

Well same problem rusted hook on the bolt...problems here changing wheel at roadside .. after soaking with diesel / oil managed to
force the spare wheel cage bar over the hook and drop..the spare wheel..
Then fitted replacement hook and bolt ... got from a scrappy Ford Ka .. yes FORD KA..they fit great and there are
loads of Ka,s awaiting crunching in the yards ... pulled up bolt then ... zipped off the head of original bolt
with acme angle grinder .( sparks had at steel/ iron surround ).... bolt fell off ... replacement on after clean and scrape by angle
grinder ...copper greased .. tightened up ...... perfect ,,, 19 mm nut now no flat bar ... easy , lazy DIY not greasing original bolt cause of
rust ..
Alb