engine problems?

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

kang0o
Posts: 16
Joined: 04 Aug 2006, 23:23

engine problems?

Post by kang0o »

Hi i have a 1999 xantia 2.0 HDI. Today the engine sounded very rough and at one point completely cut out but started again. An orange warning light on the dash board appeared, possibly a engine management light on the far left of dash board.

Any ideas? Is this terminal?

Toby_HDi
Posts: 1358
Joined: 05 Jan 2008, 22:31

Post by Toby_HDi »

Is that light still lit? It is the EM light

Any more details on the problem? Did it happen under load? on overrun? at idle?

You say it started again? did it start straight away with no problems? or did it take some cranking or sounded rough?

Is the car now running fine?

The fact the car started again certainly sounds like its not terminal - could be a dickie sensor, hard to say without further details

kang0o
Posts: 16
Joined: 04 Aug 2006, 23:23

Post by kang0o »

Hi, It started straight away but sounded rough. This morning it didn't want to start at all and when it did it sounded like it was running on half a cylinder but did sort of clear after a fews seconds of full throtle, with a massive cloud of blue smoke, but the EM light stayed off.
I put a new fuel filter on but the problem was still there. Really heavy diesel knock at low revs. It also die again, this time on restarting there was an awful noise from the back, think it might be the pump :(.
So might be looking for somewhere to get a good cheap replacement if you can recommend one.
Cheers

nick
Posts: 1079
Joined: 14 Mar 2001, 02:49

Post by nick »

kang0o wrote: this time on restarting there was an awful noise from the back, think it might be the pump :(.
So might be looking for somewhere to get a good cheap replacement if you can recommend one.
Cheers
A noise from the back of the car sounds very like the electric lift pump. Last time I bought one they were about £90 from GSF.

kang0o
Posts: 16
Joined: 04 Aug 2006, 23:23

Post by kang0o »

I brought some Forte fuel treatment on the advise of my local garage and it has definitely helped. The low rev diesel knock has almost completely gone now. Was still pretty rough when it started though. I do think somethiong maybe on it's way out.

Citroenmad
Posts: 8110
Joined: 04 Dec 2008, 23:08
x 28

Post by Citroenmad »

You could als try some forte top end treatment, to reduce noise, oil consumption and help with worn engines. Its worth a shot!

andydykes
Posts: 56
Joined: 01 Jul 2007, 20:43

Post by andydykes »

My diesel Xantia had the same sort of problem. Not wishing to be alarmist have you checked the cam belt? Mine had jumped a cog and was running like yours. Shortly afterwards the cambelt went through the cover and caused terminal damage.

I do hope you don't have the same problem.