C4 Coupe (_LA) Can’t start after failure

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Modami
Donor 2024
Posts: 7
Joined: 03 Jun 2024, 10:59
x 1

C4 Coupe (_LA) Can’t start after failure

Post by Modami »

Hello there everyone,
Super short description of problem - my wife’s car just died and it’s not firing up. I’m looking everywhere I can for some clues/tips or similarities - to fix it in case of workshop failure.

The patient is 2005, Citroen C4 Coupe (_LA) 1.6 16v (80kW/109hp) TU5JP4 if I remember correctly, equipped with Bosh ECU. Current mileage 209,5k.

What happened - I started the engine without any problems, I left it on for ~2m to let engine spread the oil. We were on the highway, going to the shop.
Suddenly this appeared “Anti Pollution System Failure” with blinking Engine Management light. Whole car started to shake. It lost whole power, but we managed to drive it 70km/h. Perfect day for malfunction - Saturday. One of workshops was still open. They connected it to Wurth and then to Lexia (I guess).

Car was still able to drive and start at this point. They’ve found vent error, but this is my fault (cheap replacement used), clutch sensor (it doesn’t have clutch sensor) and a list of codes P1336, P0351, P0352, P0353, P0354. They didn’t even checked the car - just removed all the error codes. On monday they called me to pick it up, “we are not able to fix it/we don’t know what is wrong”.

At this point - whole situation got worse.
It is spinning but it’s not able to fire up.
They said engine timing is bad. (XD)

The same day I managed to get in touch with guy focused on french cars.
It took him one day to check whole car - he couldn’t say a bad word about parts/electric system in general.
What he checked:
Engine Timing, battery, starter, dynamo, sparks, coils, cables, fuel pump pressure, fuel filter, engine fuse box/cab fuse box, lambdas, oxygen sensor, groundings, camshaft/crankshaft sensors, engine compression, injectors, actuator. At 160k we fixed full set of gasket, engine timing, water pump, sparks.

However, he noticed some strange behaviour during startup attempts - lights/indicators automatically turned on as well as wipers. In addition - irregular ignition - whatever it means.
His final conclusion = major ECU failure but he is not 100% sure. There is no SERVICE or STOP light on. No further error codes - because it cant start I guess.

Patient have some ongoing problems like:
ESP/ASR System Faulty - this one is tricky and I cant figure out what is causing it -.- The system itself works, when error comes up - it doesn’t,
Vent working on one gear - broken resistant,
Smell of petrol inside cabin - when tank is at 50% or lower and when AC is on regardless of tank level,
Limiter works but cruise control doesn’t - when I try to use CC there’s an error on display and noticeable loss of power,
Sometimes it just can’t fire up - randomly. It can’t even spin. Starter was replaced, battery also - no, no strange noises coming from engine.

Just in case here is the VIN: VF7**************[VIN obfuscated, can be read by forum staff]

I would be grateful for any help and clues what the hell happened to it. Maybe there is some small thing I should check.
Thanks in advance
Modami
Donor 2024
Posts: 7
Joined: 03 Jun 2024, 10:59
x 1

Re: C4 Coupe (_LA) Can’t start after failure

Post by Modami »

Small update - since there is no reply here, after almost a month I got PCM/BSI/ECU back. No issues found within them and the car is dead - not firing up.
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38581
Joined: 15 Sep 2015, 19:38
x 6011

Re: C4 Coupe (_LA) Can’t start after failure

Post by GiveMeABreak »

I've only just seen this post, but unfortunately the older petrol engines have very little in the way of diagnostic info apart from the basic fault code.

Just to get the issue with the cruise control out the way, that is perfectly normal if there is anything wrong with the engine ECU or the data - as it disables cruise control for safety reasons, so ignore that for now.

But I think your garage may be correct. Electrical failure like this may indicate a faulty engine ECU that is causing the issues with the coils, which of course won't start the engine without power. The petrol smell may be because of the flooding or constant starting attempts and also may be that the petrol vapour capture system is not working either.

P1336 Combustion misfiring on unspecified cylinders fault: Not characterised
P0351 Fault: control of ignition coils 1/4: Short circuit to positive
P0352 Fault: control of ignition coils 2/3: Short circuit to positive

It's really going to be hard for anyone here to help much further to be honest as it looks like it needs an electrical specialist to check the engine ECU and or the BSI for correct operation.

Also, one other thing, you mentioned about the wipers and the indicators - both these are controlled by the engine fuse box - so that will add weight to a potential problem with the fuse box. I suggest you may want to change this with a working second hand one and see if this resolves any of the above.
Please Don't PM Me For Technical Help

Marc
Modami
Donor 2024
Posts: 7
Joined: 03 Jun 2024, 10:59
x 1

Re: C4 Coupe (_LA) Can’t start after failure

Post by Modami »

That’s what I was thinking all the time. But yea… now I’m completely out of ideas. ECU/PCM/BSI checked by professional service - in tests, everything is working properly. So now I’m guessing - maybe there is bad grounding somewhere. Or maybe immobiliser but this one I think they checked during tests so I assume its okay.

I can’t refer to anything :/ Even connecting to diagbox/lexia doesn’t give a single clue what is possibly wrong.
Steve Walsh
Donor 2024
Posts: 489
Joined: 25 Oct 2019, 07:20
x 376

Re: C4 Coupe (_LA) Can’t start after failure

Post by Steve Walsh »

Are you using the correct key, Some have a chip in and it wont start without.
Just worth checking the basics before digging to deep
Thanx to Marc and all the admins & knowledgeable people that make this the best forum on the interweb. =D> =D> =D>
Modami
Donor 2024
Posts: 7
Joined: 03 Jun 2024, 10:59
x 1

Re: C4 Coupe (_LA) Can’t start after failure

Post by Modami »

Hehe yes, its still original key. With fresh battery in remote. It recognises both keys, I didn’t noticed Anti Theft message on my dash as well.
Bela-Khun
Posts: 2
Joined: 02 Jul 2024, 17:53

Re: C4 Coupe (_LA) Can’t start after failure

Post by Bela-Khun »

Hi Gentelmen, I have similar problem on my C4 1.4 petrol anti pollution system fault. The engine starts properly but I can see a message anti pollution system fault. I had a same problem on my C5 II 2.0 HD and i got an information from Citroen that the problem is with wires or with a grounding some wire. They told me, it's a marginal problem and you can drive without problems of car. OK, I drove my car and suddenly engine stopped, and I had to use Euroasistance to carry my car to other Citroen service two hundred kilometrs from my home. They called me from that service and told me about a problem with my car. The proble was a faulty BSM and DPF/FAP. I had to pay $4000 for a repairing. If the problem was found early I could pay for a faulty BSM $500 only.
I don't want to pay for my C4 repairing same value like for my C5 repairing. I would rather to change BSM or EGR than the entire exhaust system.
Modami
Donor 2024
Posts: 7
Joined: 03 Jun 2024, 10:59
x 1

Re: C4 Coupe (_LA) Can’t start after failure

Post by Modami »

As long as your engine starts get it fixed and don’t drive it.
I was about to write the final words about my one.
Personally I have performed dozen of other tests as well.

So… The reason why is my car not firing up is no sync between crankshaft<>camshaft. I don’t know how in the name of god it happened. Both sensors works perfectly fine, pulley is also okay (I was thinking the chock is broken .. I think that’s the name of it). None of “computers” report any sync related error when I was trying to start the car. So that’s the end of story. Now in addition to multiple start attempts of mechanic there is knocking metallic noise inside the engine. I’m also thinking the workshop that replaced gasket screwed up couple of things.
Bela-Khun
Posts: 2
Joined: 02 Jul 2024, 17:53

Re: C4 Coupe (_LA) Can’t start after failure

Post by Bela-Khun »

Modami wrote: 02 Jul 2024, 19:01 As long as your engine starts get it fixed and don’t drive it.
I was about to write the final words about my one.
Personally I have performed dozen of other tests as well.

So… The reason why is my car not firing up is no sync between crankshaft<>camshaft. I don’t know how in the name of god it happened. Both sensors works perfectly fine, pulley is also okay (I was thinking the chock is broken .. I think that’s the name of it). None of “computers” report any sync related error when I was trying to start the car. So that’s the end of story. Now in addition to multiple start attempts of mechanic there is knocking metallic noise inside the engine. I’m also thinking the workshop that replaced gasket screwed up couple of things.
I think the main problem is in the engine control unit. It's sending the wrong commands because it has a bad algorithm for processing the pulses from the sensors. My sensors were all fine too, but one circuit in the control unit (BSM) was burnt out and was sending the wrong control codes. It got to the point where the engine shut down. My diagnostics were reporting codes:
P0101 Mass or Volume Air Flow Circuit Range/Performance Problem
P0102 Mass or Volume Air Flow Circuit Low Input
P0112 Intake Air Temperature Circuit Low Input
P0113 Intake Air Temperature Circuit High Input
P0130 O2 Sensor Circuit Malfunction (Bank 1 Sensor 1)
P0131 O2 Sensor Circuit Low Voltage (Bank 1 Sensor 1)
P0132 O2 Sensor Circuit High Voltage (Bank 1 Sensor 1)
P0133 O2 Sensor Circuit Slow Response (Bank 1 Sensor 1)
P0134 O2 Sensor Circuit No Activity Detected (Bank 1 Sensor 1)
P0135 O2 Sensor Heater Circuit Malfunction (Bank 1 Sensor 1)
I was very confused. The information about a mulfunction of anti pollution system was appeared. Citroen service deleted these messages from log and it seemed it could be OK. After one or two hundred kilometers the mulfunction of anti pollution system appeared again and then the car stopped.
A marginal problem can lead to big problem as in my case. I changed whole an exhaust system and an engine control unit.
Modami
Donor 2024
Posts: 7
Joined: 03 Jun 2024, 10:59
x 1

Re: C4 Coupe (_LA) Can’t start after failure

Post by Modami »

Wellp.. My guy checked ECU/BSM/PCM/ - because the only sensor reporting problem was camshaft sensor. Crankshaft sensor was quiet and it still doesn’t report any problem. For now on, I just put the car in my garage, maybe I will look for an engine to swap it. It’s difficult to say what is damaged inside now :/

But I’m curious… why only camshaft reported fault and not the crankshaft ;?
User avatar
MattBLancs
Donor 2024
Posts: 2782
Joined: 25 Apr 2022, 09:03
x 1493

Re: C4 Coupe (_LA) Can’t start after failure

Post by MattBLancs »

Don't forget a fault code is generated by what the engine ECU thinks is wrong. So it looks at crankshaft and camshaft sensor values and detects they don't match - logs a fault and in your case it has determined it is the camshaft sensor that isn't functioning.